Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 1 | require xorg-driver-video.inc |
| 2 | |
| 3 | SUMMARY = "X.Org X server -- Intel integrated graphics chipsets driver" |
| 4 | |
| 5 | DESCRIPTION = "intel is an Xorg driver for Intel integrated graphics \ |
| 6 | chipsets. The driver supports depths 8, 15, 16 and 24. On some chipsets, \ |
| 7 | the driver supports hardware accelerated 3D via the Direct Rendering \ |
| 8 | Infrastructure (DRI)." |
| 9 | |
| 10 | LIC_FILES_CHKSUM = "file://COPYING;md5=8730ad58d11c7bbad9a7066d69f7808e" |
| 11 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 12 | SRCREV = "e4fe79cf0d9a05ee3f3a027148ef0aeb2b1b34e1" |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 13 | PV = "2.99.917+git${SRCPV}" |
| 14 | S = "${WORKDIR}/git" |
| 15 | |
| 16 | SRC_URI = "git://anongit.freedesktop.org/xorg/driver/xf86-video-intel \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 17 | file://0001-Add-Coffeelake-PCI-IDs-for-S-Skus.patch \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 18 | file://glibc.patch \ |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 19 | " |
| 20 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 21 | UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+(\.\d+)+)" |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 22 | |
| 23 | DEPENDS += "virtual/libx11 drm libpciaccess pixman" |
| 24 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 25 | PACKAGECONFIG ??= "xvmc uxa udev ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'dri dri2 dri3', '', d)}" |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 26 | |
| 27 | PACKAGECONFIG[dri] = "--enable-dri,--disable-dri" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 28 | PACKAGECONFIG[dri1] = "--enable-dri1,--disable-dri1" |
| 29 | PACKAGECONFIG[dri2] = "--enable-dri2,--disable-dri2" |
| 30 | PACKAGECONFIG[dri3] = "--enable-dri3,--disable-dri3" |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 31 | PACKAGECONFIG[sna] = "--enable-sna,--disable-sna" |
| 32 | PACKAGECONFIG[uxa] = "--enable-uxa,--disable-uxa" |
| 33 | PACKAGECONFIG[udev] = "--enable-udev,--disable-udev,udev" |
| 34 | PACKAGECONFIG[xvmc] = "--enable-xvmc,--disable-xvmc,libxvmc xcb-util" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 35 | PACKAGECONFIG[tools] = "--enable-tools,--disable-tools,libxinerama libxrandr libxdamage libxfixes libxcursor libxtst libxrender libxscrnsaver libxext libx11 pixman libxcb libxshmfence" |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 36 | |
| 37 | # --enable-kms-only option is required by ROOTLESS_X |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 38 | EXTRA_OECONF += '${@oe.utils.conditional( "ROOTLESS_X", "1", " --enable-kms-only", "", d )}' |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 39 | |
| 40 | COMPATIBLE_HOST = '(i.86|x86_64).*-linux' |
| 41 | |
| 42 | FILES_${PN} += "${datadir}/polkit-1" |