Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | SUMMARY = "GStreamer examples (including gtk-play, gst-play)" |
| 2 | LICENSE = "LGPL-2.0+" |
| 3 | LIC_FILES_CHKSUM = "file://playback/player/gtk/gtk-play.c;beginline=1;endline=20;md5=f8c72dae3d36823ec716a9ebcae593b9" |
| 4 | |
| 5 | DEPENDS = "glib-2.0 gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad gtk+3 glib-2.0-native" |
| 6 | |
| 7 | SRC_URI = "git://anongit.freedesktop.org/gstreamer/gst-examples \ |
| 8 | file://0001-Make-player-examples-installable.patch \ |
| 9 | file://gst-player.desktop" |
| 10 | |
| 11 | SRCREV = "48247c6ab6807d6ae179cf653cbdc64714d3313c" |
| 12 | PV = "0.0.1+git${SRCPV}" |
| 13 | UPSTREAM_CHECK_COMMITS = "1" |
| 14 | |
| 15 | S = "${WORKDIR}/git" |
| 16 | |
| 17 | inherit meson pkgconfig distro_features_check |
| 18 | |
| 19 | |
| 20 | ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}" |
| 21 | |
| 22 | do_install_append() { |
| 23 | install -m 0644 -D ${WORKDIR}/gst-player.desktop ${D}${datadir}/applications/gst-player.desktop |
| 24 | } |
| 25 | |
| 26 | RDEPENDS_${PN} = "gstreamer1.0-plugins-base-playback" |
| 27 | RRECOMMENDS_${PN} = "gstreamer1.0-plugins-base-meta \ |
| 28 | gstreamer1.0-plugins-good-meta \ |
| 29 | gstreamer1.0-plugins-bad-meta \ |
| 30 | ${@bb.utils.contains("LICENSE_FLAGS_WHITELIST", "commercial", "gstreamer1.0-libav", "", d)} \ |
| 31 | ${@bb.utils.contains("LICENSE_FLAGS_WHITELIST", "commercial", "gstreamer1.0-plugins-ugly-meta", "", d)}" |
| 32 | RPROVIDES_${PN} += "gst-player gst-player-bin" |