Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | SUMMARY = "Cap'n Proto serialization/RPC system" |
| 2 | DESCRIPTION = "Cap’n Proto is an insanely fast data interchange format and capability-based RPC system. " |
| 3 | HOMEPAGE = "https://github.com/sandstorm-io/capnproto" |
| 4 | SECTION = "console/tools" |
| 5 | |
| 6 | LICENSE = "MIT" |
| 7 | LIC_FILES_CHKSUM = "file://../LICENSE;md5=0a5b5b742baf10cc1c158579eba7fb1d" |
| 8 | |
| 9 | SRCREV = "c949a18da5f041a36cc218c5c4b79c7705999b4f" |
| 10 | SRC_URI = "git://github.com/sandstorm-io/capnproto.git;branch=release-${PV}" |
| 11 | |
| 12 | EXTRA_OECMAKE += "\ |
| 13 | -DBUILD_TESTING=OFF \ |
| 14 | " |
| 15 | |
| 16 | inherit cmake |
| 17 | |
| 18 | S = "${WORKDIR}/git/c++" |
| 19 | |
| 20 | PACKAGE_BEFORE_PN = "${PN}-compiler" |
| 21 | RDEPENDS_${PN}-dev += "${PN}-compiler" |
| 22 | |
| 23 | FILES_${PN}-dev += "${libdir}/cmake" |
| 24 | FILES_${PN}-compiler = "${bindir}" |
| 25 | |
| 26 | BBCLASSEXTEND = "native nativesdk" |