blob: 0ea731c356b161ef205d03555d3b7af890d4287b [file] [log] [blame]
George Hungf089ba12020-05-20 17:22:25 +08001PR = "r1"
2LICENSE = "Apache-2.0 & BSD-3-Clause"
3LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10 \
4 file://${COREBASE}/meta/files/common-licenses/BSD-3-Clause;md5=550794465ba0ec5312d6919e203a55f9 \
5 "
6
7inherit systemd
8inherit obmc-phosphor-systemd
9
10
11DEPENDS += "systemd"
12DEPENDS += "phosphor-ipmi-flash"
13RDEPENDS_${PN} += "bash"
14
George Hunge60f2ac2021-05-20 18:53:06 +080015PROVIDES += "virtual/bios-update"
16RPROVIDES_${PN} += "virtual/bios-update"
17
George Hungf089ba12020-05-20 17:22:25 +080018SRC_URI += " file://bios-verify.sh \
19 file://bios-update.sh \
20 file://phosphor-ipmi-flash-bios-verify.service \
21 file://phosphor-ipmi-flash-bios-update.service \
22 file://config-bios.json \
23 "
24
25FILES_${PN} += "${datadir}/phosphor-ipmi-flash/config-bios.json"
26
27do_install() {
28 install -d ${D}${bindir}
29 install -m 0755 ${WORKDIR}/bios-verify.sh ${D}${bindir}/
30 install -m 0755 ${WORKDIR}/bios-update.sh ${D}${bindir}/
31
32 install -d ${D}${systemd_system_unitdir}
33 install -m 0644 ${WORKDIR}/phosphor-ipmi-flash-bios-verify.service ${D}${systemd_system_unitdir}
34 install -m 0644 ${WORKDIR}/phosphor-ipmi-flash-bios-update.service ${D}${systemd_system_unitdir}
35
36 install -d ${D}${datadir}/phosphor-ipmi-flash
37 install -m 0644 ${WORKDIR}/config-bios.json ${D}${datadir}/phosphor-ipmi-flash
38}
39
40
41SYSTEMD_PACKAGES = "${PN}"
42SYSTEMD_SERVICE_${PN} = "phosphor-ipmi-flash-bios-verify.service phosphor-ipmi-flash-bios-update.service"