Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Filesystem and Disk Benchmarking Tool" |
| 2 | HOMEPAGE = "http://www.iozone.org/" |
| 3 | AUTHOR = "Don Capps <don.capps2@verizon.net>, William D. Norcott <wnorcott@us.oracle.com>" |
| 4 | SECTION = "console/tests" |
| 5 | LICENSE = "iozone3" |
| 6 | LIC_FILES_CHKSUM = "file://iozone.c;beginline=37;endline=48;md5=7331260091868dcad0f9edea735b5f4b \ |
| 7 | file://iozone.c;beginline=276;endline=282;md5=77f9ee51e45b57a7e7519c4fa0b4f00b \ |
| 8 | " |
| 9 | SRC_URI = "http://www.iozone.org/src/current/${BPN}_${PV}.tar \ |
| 10 | file://parallelism.patch \ |
| 11 | file://0001-let-system-headers-provide-pread64.patch \ |
| 12 | file://copyright.txt \ |
| 13 | " |
Andrew Geissler | 6972109 | 2021-07-23 12:57:00 -0400 | [diff] [blame] | 14 | SRC_URI[md5sum] = "228f54482c01d1c04c571a9414cd20e5" |
| 15 | SRC_URI[sha256sum] = "322981e168f32bd39f54772b82b2906d598d958c37e954e75742e71baf58bb9b" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 16 | |
| 17 | UPSTREAM_CHECK_REGEX = "iozone3_(?P<pver>\d+).tar" |
| 18 | |
Andrew Geissler | a2681d9 | 2020-10-16 10:17:07 -0500 | [diff] [blame] | 19 | S = "${WORKDIR}/${BPN}_${PV}/src/current" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 20 | |
| 21 | # |
| 22 | # All other arches can use the default OEMAKE except those |
| 23 | # explicitly listed below. Another, the iozone3 Makefile |
| 24 | # needs to be told about the cross-compiler explicitly here. |
| 25 | # |
| 26 | EXTRA_OEMAKE_powerpc = "linux-powerpc CC='${CC}' GCC='${CC}'" |
| 27 | EXTRA_OEMAKE_powerpc64 = "linux-powerpc64 CC='${CC}' GCC='${CC}'" |
| 28 | EXTRA_OEMAKE_powerpc64le = "linux-powerpc64 CC='${CC}' GCC='${CC}'" |
| 29 | EXTRA_OEMAKE_x86-64 = "linux-AMD64 CC='${CC}' GCC='${CC}'" |
| 30 | EXTRA_OEMAKE_arm = "linux-arm CC='${CC}' GCC='${CC}'" |
| 31 | EXTRA_OEMAKE = "linux CC='${CC}' GCC='${CC}'" |
| 32 | |
| 33 | TARGET_CC_ARCH += "${LDFLAGS}" |
| 34 | |
| 35 | do_install() { |
| 36 | install -d ${D}${bindir} \ |
| 37 | ${D}${mandir}/man1 \ |
| 38 | ${D}${datadir}/doc/${BPN}/examples |
| 39 | |
| 40 | install -m 0755 ${S}/iozone ${D}${bindir} |
| 41 | install -m 0755 ${S}/fileop ${D}${bindir} |
| 42 | install -m 0644 ${WORKDIR}/${BPN}_${PV}/docs/iozone.1 ${D}${mandir}/man1/ |
| 43 | install -m 0644 ${WORKDIR}/copyright.txt ${D}${datadir}/doc/${BPN}/ |
| 44 | |
| 45 | install -m 0644 ${S}/*.dem ${D}${datadir}/doc/${BPN}/examples |
| 46 | install -m 0644 ${S}/client_list ${D}${datadir}/doc/${BPN}/examples |
| 47 | install -m 0644 ${S}/Gnuplot.txt ${D}${datadir}/doc/${BPN}/examples |
| 48 | |
| 49 | install -m 0755 ${S}/Generate_Graphs ${D}${datadir}/doc/${BPN}/examples |
| 50 | install -m 0755 ${S}/gengnuplot.sh ${D}${datadir}/doc/${BPN}/examples |
| 51 | install -m 0755 ${S}/report.pl ${D}${datadir}/doc/${BPN}/examples |
| 52 | |
| 53 | install -m 0644 ${WORKDIR}/${BPN}_${PV}/docs/Iozone_ps.gz ${D}${datadir}/doc/${BPN}/ |
| 54 | install -m 0644 ${WORKDIR}/${BPN}_${PV}/docs/IOzone_msword_98.pdf ${D}${datadir}/doc/${BPN}/ |
| 55 | install -m 0644 ${WORKDIR}/${BPN}_${PV}/docs/Run_rules.doc ${D}${datadir}/doc/${BPN}/ |
| 56 | } |
| 57 | |
| 58 | FILES_${PN} += "${datadir}/doc/${PN}/copyright.txt" |
| 59 | |
| 60 | # LICENSE: |
| 61 | # |
| 62 | # Copyright 1991, 1992, 1994, 1998, 1999, 2002 William D. Norcott |
| 63 | # |
| 64 | # License to freely use and distribute this software is hereby granted |
| 65 | # by the author, subject to the condition that this copyright notice |
| 66 | # remains intact. The author retains the exclusive right to publish |
| 67 | # derivative works based on this work, including, but not limited to |
| 68 | # revised versions of this work. |
| 69 | # |
| 70 | |
| 71 | # |
| 72 | # Below is author reply to question about distributing iozone3 in |
| 73 | # OpenEmbedded: |
| 74 | # |
| 75 | # ======================================================================== |
| 76 | # |
| 77 | # Marcin, |
| 78 | # |
| 79 | # Re-distribution is permitted as long as the copyright is |
| 80 | # maintained and the source code is not changed. I do not |
| 81 | # see a problem with your mods to enable fileop for Linux-arm, |
| 82 | # as these mods have been returned to the Iozone folks, |
| 83 | # and they have been accepted for inclusion in the next |
| 84 | # release :-) |
| 85 | # |
| 86 | # Thank you for your contribution, |
| 87 | # Don Capps |
| 88 | # |
| 89 | # ----- Original Message ----- |
| 90 | # From: "Marcin Juszkiewicz" <firma@hrw.one.pl> |
| 91 | # To: "Don Capps" <don.capps2@verizon.net>; "William D. Norcott" |
| 92 | # <wnorcott@us.oracle.com> |
| 93 | # Sent: Sunday, October 29, 2006 4:55 PM |
| 94 | # Subject: iozone3 263 patch for arm and License question |
| 95 | # |
| 96 | # |
| 97 | # > Morning |
| 98 | # > |
| 99 | # > I want to include iozone3 in OpenEmbedded [1] metadata to give it for |
| 100 | # > other developers. Currently OE is used to build few distributions for |
| 101 | # > misc platforms: ARM, SH3, SH4, x86, PowerPC and different types of |
| 102 | # > machines (PDA, settopbox, devboards, desktops, thin clients, routers). |
| 103 | # > |
| 104 | # > According to your distribution of derivations is forbidden. Packaging |
| 105 | # > iozone3 in OpenEmbedded will not involve any source code changes. But |
| 106 | # > when I was building it for ARM I discovered that fileop binary was not |
| 107 | # > built - so I created patch for it (attached). Not yet tested it on target |
| 108 | # > device. |
| 109 | # > |
| 110 | # > Thus, I seek your written permission via e-mail to distribute a package of |
| 111 | # > the unmodified source code and also a package of the pre-compiled binary. |
| 112 | # > Your copyright statement will be included in the package. |
| 113 | # > |
| 114 | # > |
| 115 | # > 1. http://www.openembedded.org/ |
| 116 | # > |
| 117 | # > Regards |
| 118 | # > -- |
| 119 | # > JID: hrw-jabber.org |
| 120 | # > OpenEmbedded developer/consultant |
| 121 | |