Andrew Geissler | c87764f | 2020-06-27 00:16:32 -0500 | [diff] [blame] | 1 | SUMMARY = "IPy - class and tools for handling of IPv4 and IPv6 addresses and networks" |
| 2 | DESCRIPTION = "IPy is a Python module for handling IPv4 and IPv6 Addresses and Networks \ |
| 3 | in a fashion similar to perl's Net::IP and friends. The IP class allows \ |
| 4 | a comfortable parsing and handling for most notations in use for IPv4 \ |
| 5 | and IPv6 Addresses and Networks." |
| 6 | SECTION = "devel/python" |
| 7 | HOMEPAGE = "https://github.com/autocracy/python-ipy" |
| 8 | |
| 9 | LICENSE = "BSD-3-Clause" |
| 10 | LIC_FILES_CHKSUM = "file://COPYING;md5=848d24919845901b4f48bae5f13252e6" |
| 11 | |
Andrew Geissler | eef6386 | 2021-01-29 15:58:13 -0600 | [diff] [blame] | 12 | SRC_URI[md5sum] = "d6cf83e7f418ebbd23324ba1c658b907" |
| 13 | SRC_URI[sha256sum] = "edeca741dea2d54aca568fa23740288c3fe86c0f3ea700344571e9ef14a7cc1a" |
Andrew Geissler | c87764f | 2020-06-27 00:16:32 -0500 | [diff] [blame] | 14 | |
| 15 | inherit pypi setuptools3 ptest |
| 16 | |
| 17 | SRC_URI += " \ |
| 18 | file://run-ptest \ |
| 19 | " |
| 20 | |
| 21 | RDEPENDS_${PN}-ptest += " \ |
| 22 | ${PYTHON_PN}-pytest \ |
| 23 | " |
| 24 | |
| 25 | do_install_ptest() { |
| 26 | install -d ${D}${PTEST_PATH}/test/ |
| 27 | cp -rf ${S}/test/* ${D}${PTEST_PATH}/test |
| 28 | } |
| 29 | |
| 30 | PYPI_PACKAGE = "IPy" |
| 31 | |
| 32 | BBCLASSEXTEND = "native" |