Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "A simple, safe single expression evaluator library" |
| 2 | HOMEPAGE = "https://pypi.org/project/simpleeval/" |
| 3 | LICENSE = "MIT" |
| 4 | LIC_FILES_CHKSUM = "file://LICENCE;md5=dc9277482effe59b734b004cbcc1fee7" |
| 5 | |
| 6 | SRC_URI[md5sum] = "f175fc12d408487ca26fa3905e0a6691" |
| 7 | SRC_URI[sha256sum] = "692055488c2864637f6c2edb5fa48175978a2a07318009e7cf03c9790ca17bea" |
| 8 | |
| 9 | inherit pypi setuptools3 ptest |
| 10 | |
| 11 | BBCLASSEXTEND = "native nativesdk" |
| 12 | |
| 13 | SRC_URI += " \ |
| 14 | file://run-ptest \ |
| 15 | " |
| 16 | |
| 17 | RDEPENDS_${PN}-ptest += " \ |
| 18 | ${PYTHON_PN}-pytest \ |
| 19 | " |
| 20 | |
| 21 | do_install_ptest() { |
| 22 | cp -f ${S}/test_simpleeval.py ${D}${PTEST_PATH}/ |
| 23 | } |