Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "GNU grep utility" |
| 2 | HOMEPAGE = "http://savannah.gnu.org/projects/grep/" |
Andrew Geissler | 95ac1b8 | 2021-03-31 14:34:31 -0500 | [diff] [blame] | 3 | DESCRIPTION = "Grep searches one or more input files for lines containing a match to a specified pattern. By default, grep prints the matching lines." |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 4 | BUGTRACKER = "http://savannah.gnu.org/bugs/?group=grep" |
| 5 | SECTION = "console/utils" |
| 6 | LICENSE = "GPLv3" |
| 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=1ebbd3e34237af26da5dc08a4e440464" |
| 8 | |
| 9 | SRC_URI = "${GNU_MIRROR}/grep/grep-${PV}.tar.xz" |
| 10 | |
Andrew Geissler | 09209ee | 2020-12-13 08:44:15 -0600 | [diff] [blame] | 11 | SRC_URI[sha256sum] = "667e15e8afe189e93f9f21a7cd3a7b3f776202f417330b248c2ad4f997d9373e" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 12 | |
| 13 | inherit autotools gettext texinfo pkgconfig |
| 14 | |
| 15 | # Fix "Argument list too long" error when len(TMPDIR) = 410 |
| 16 | acpaths = "-I ./m4" |
| 17 | |
| 18 | do_configure_prepend () { |
| 19 | sed -i -e '1s,#!@SHELL@,#!/bin/sh,' ${S}/src/egrep.sh |
| 20 | rm -f ${S}/m4/init.m4 |
| 21 | } |
| 22 | |
| 23 | do_install () { |
| 24 | autotools_do_install |
| 25 | if [ "${base_bindir}" != "${bindir}" ]; then |
| 26 | install -d ${D}${base_bindir} |
| 27 | mv ${D}${bindir}/grep ${D}${base_bindir}/grep |
| 28 | mv ${D}${bindir}/egrep ${D}${base_bindir}/egrep |
| 29 | mv ${D}${bindir}/fgrep ${D}${base_bindir}/fgrep |
| 30 | rmdir ${D}${bindir}/ |
| 31 | fi |
| 32 | } |
| 33 | |
| 34 | inherit update-alternatives |
| 35 | |
| 36 | PACKAGECONFIG ??= "pcre" |
| 37 | PACKAGECONFIG[pcre] = "--enable-perl-regexp,--disable-perl-regexp,libpcre" |
| 38 | |
| 39 | ALTERNATIVE_PRIORITY = "100" |
| 40 | |
| 41 | ALTERNATIVE_${PN} = "grep egrep fgrep" |
| 42 | ALTERNATIVE_LINK_NAME[grep] = "${base_bindir}/grep" |
| 43 | ALTERNATIVE_LINK_NAME[egrep] = "${base_bindir}/egrep" |
| 44 | ALTERNATIVE_LINK_NAME[fgrep] = "${base_bindir}/fgrep" |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 45 | |
| 46 | BBCLASSEXTEND = "nativesdk" |