Andrew Geissler | 3b8a17c | 2021-04-15 15:55:55 -0500 | [diff] [blame] | 1 | require mesa.inc |
| 2 | |
| 3 | SUMMARY += " (OpenGL only, no EGL/GLES)" |
| 4 | |
| 5 | PROVIDES = "virtual/libgl virtual/mesa" |
| 6 | |
| 7 | S = "${WORKDIR}/mesa-${PV}" |
| 8 | |
| 9 | # At least one DRI rendering engine is required to build mesa. |
| 10 | # When no X11 is available, use osmesa for the rendering engine. |
| 11 | PACKAGECONFIG ??= "opengl dri ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', 'osmesa gallium', d)}" |
| 12 | PACKAGECONFIG_class-target = "opengl dri ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', 'osmesa gallium', d)}" |
| 13 | |
| 14 | # 21.0.0 version fails to build when any driver is enabled in DRIDRIVERS |
| 15 | # ./mesa-21.0.0/meson.build:519:4: ERROR: Problem encountered: building dri drivers require at least one windowing system |
| 16 | DRIDRIVERS ?= "" |