Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | SUMMARY = "Free and Open On-Chip Debugging, In-System Programming and Boundary-Scan Testing" |
| 2 | LICENSE = "GPLv2" |
| 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 4 | DEPENDS = "libusb-compat libftdi" |
| 5 | RDEPENDS_${PN} = "libusb1" |
| 6 | |
Brad Bishop | 757e94a | 2018-09-07 18:58:51 +0000 | [diff] [blame] | 7 | SRC_URI = " \ |
| 8 | git://repo.or.cz/openocd.git;protocol=http;name=openocd \ |
| 9 | git://repo.or.cz/r/git2cl.git;protocol=http;destsuffix=tools/git2cl;name=git2cl \ |
| 10 | git://repo.or.cz/r/jimtcl.git;protocol=http;destsuffix=git/jimtcl;name=jimtcl \ |
| 11 | git://repo.or.cz/r/libjaylink.git;protocol=http;destsuffix=git/src/jtag/drivers/libjaylink;name=libjaylink \ |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 12 | file://0001-esirisc_flash-Rename-PAGE_SIZE-to-FLASH_PAGE_SIZE.patch \ |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 13 | file://0001-Do-not-include-syscrtl.h-with-glibc.patch \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 14 | " |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 15 | |
Brad Bishop | 757e94a | 2018-09-07 18:58:51 +0000 | [diff] [blame] | 16 | SRCREV_FORMAT = "openocd" |
Brad Bishop | ba6de43 | 2019-05-21 08:07:33 -0400 | [diff] [blame] | 17 | SRCREV_openocd = "7ee618692f56b0efea864890da45d73d28e393d9" |
Brad Bishop | 757e94a | 2018-09-07 18:58:51 +0000 | [diff] [blame] | 18 | SRCREV_git2cl = "8373c9f74993e218a08819cbcdbab3f3564bbeba" |
| 19 | SRCREV_jimtcl = "a9bf5975fd0f89974d689a2d9ebd0873c8d64787" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 20 | SRCREV_libjaylink = "8645845c1abebd004e991ba9a7f808f4fd0c608b" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 21 | |
| 22 | PV = "0.10+gitr${SRCPV}" |
| 23 | S = "${WORKDIR}/git" |
| 24 | |
| 25 | inherit pkgconfig autotools-brokensep gettext |
| 26 | |
| 27 | BBCLASSEXTEND += "nativesdk" |
| 28 | |
Brad Bishop | a891d15 | 2019-09-13 06:17:45 -0400 | [diff] [blame] | 29 | EXTRA_OECONF = "--enable-ftdi --disable-doxygen-html --disable-werror" |
| 30 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 31 | do_configure() { |
Brad Bishop | 757e94a | 2018-09-07 18:58:51 +0000 | [diff] [blame] | 32 | ./bootstrap nosubmodule |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 33 | install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.guess ${S}/jimtcl/autosetup |
| 34 | install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.sub ${S}/jimtcl/autosetup |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 35 | oe_runconf ${EXTRA_OECONF} |
| 36 | } |
| 37 | |
| 38 | do_install() { |
| 39 | oe_runmake DESTDIR=${D} install |
| 40 | if [ -e "${D}${infodir}" ]; then |
| 41 | rm -Rf ${D}${infodir} |
| 42 | fi |
| 43 | if [ -e "${D}${mandir}" ]; then |
| 44 | rm -Rf ${D}${mandir} |
| 45 | fi |
| 46 | if [ -e "${D}${bindir}/.debug" ]; then |
| 47 | rm -Rf ${D}${bindir}/.debug |
| 48 | fi |
| 49 | } |
| 50 | |
| 51 | FILES_${PN} = " \ |
| 52 | ${datadir}/openocd/* \ |
| 53 | ${bindir}/openocd \ |
| 54 | " |
| 55 | |
| 56 | PACKAGECONFIG[sysfsgpio] = "--enable-sysfsgpio,--disable-sysfsgpio" |
| 57 | PACKAGECONFIG ??= "sysfsgpio" |