Andrew Geissler | a2681d9 | 2020-10-16 10:17:07 -0500 | [diff] [blame] | 1 | # Copyright (C) 2020 Armin Kuster <akuster808@gmail.com> |
| 2 | # Released under the MIT license (see COPYING.MIT for the terms) |
| 3 | |
| 4 | DESCRIPTION = "Musl-nscd is an implementation of the NSCD protocol, suitable for use with musl and with standard NSS modules" |
| 5 | HOMEPAGE = "https://github.com/pikhq/musl-nscd" |
| 6 | LICENSE = "MIT" |
| 7 | LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=9bf479a145bcaff8489e743da58afeee" |
| 8 | SECTION = "utils" |
| 9 | |
Andrew Geissler | 4b7c115 | 2020-11-30 19:55:29 -0600 | [diff] [blame] | 10 | DEPENDS += "flex-native bison-native flex bison" |
| 11 | |
Andrew Geissler | a2681d9 | 2020-10-16 10:17:07 -0500 | [diff] [blame] | 12 | PV = "1.0.2" |
| 13 | |
Andrew Geissler | 4b7c115 | 2020-11-30 19:55:29 -0600 | [diff] [blame] | 14 | SRCREV = "af581482a3e1059458f3c8b20a56f82807ca3bd4" |
| 15 | SRC_URI = "git://github.com/pikhq/musl-nscd \ |
| 16 | file://0001-Fix-build-under-GCC-fno-common.patch \ |
| 17 | file://0001-configure-Check-for-flex-if-lex-is-not-found.patch \ |
| 18 | " |
Andrew Geissler | a2681d9 | 2020-10-16 10:17:07 -0500 | [diff] [blame] | 19 | |
| 20 | UPSTREAM_CHECK_COMMITS = "1" |
| 21 | |
| 22 | inherit autotools-brokensep |
| 23 | |
| 24 | S = "${WORKDIR}/git" |
| 25 | |
| 26 | do_configure () { |
| 27 | # no debug set -s flag |
| 28 | sed -i -e 's/LDFLAGS_AUTO=-s/LDFLAGS_AUTO=/' ${S}/configure |
| 29 | ${S}/configure ${CONFIGUREOPTS} ${EXTRA_OECONF} |
| 30 | } |
| 31 | |
| 32 | do_compile () { |
| 33 | oe_runmake |
| 34 | } |
| 35 | |
| 36 | do_install () { |
| 37 | make DESTDIR=${D} install |
| 38 | } |
| 39 | |
| 40 | COMPATIBLE_HOST = ".*-musl.*" |