blob: 83125a1ba43e66215dd53ec2f556a692ddfdf391 [file] [log] [blame]
Andrew Geisslera2681d92020-10-16 10:17:07 -05001# Copyright (C) 2020 Armin Kuster <akuster808@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4DESCRIPTION = "Musl-nscd is an implementation of the NSCD protocol, suitable for use with musl and with standard NSS modules"
5HOMEPAGE = "https://github.com/pikhq/musl-nscd"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=9bf479a145bcaff8489e743da58afeee"
8SECTION = "utils"
9
Andrew Geissler4b7c1152020-11-30 19:55:29 -060010DEPENDS += "flex-native bison-native flex bison"
11
Andrew Geisslera2681d92020-10-16 10:17:07 -050012PV = "1.0.2"
13
Andrew Geissler4b7c1152020-11-30 19:55:29 -060014SRCREV = "af581482a3e1059458f3c8b20a56f82807ca3bd4"
15SRC_URI = "git://github.com/pikhq/musl-nscd \
16 file://0001-Fix-build-under-GCC-fno-common.patch \
17 file://0001-configure-Check-for-flex-if-lex-is-not-found.patch \
18 "
Andrew Geisslera2681d92020-10-16 10:17:07 -050019
20UPSTREAM_CHECK_COMMITS = "1"
21
22inherit autotools-brokensep
23
24S = "${WORKDIR}/git"
25
26do_configure () {
27 # no debug set -s flag
28 sed -i -e 's/LDFLAGS_AUTO=-s/LDFLAGS_AUTO=/' ${S}/configure
29 ${S}/configure ${CONFIGUREOPTS} ${EXTRA_OECONF}
30}
31
32do_compile () {
33 oe_runmake
34}
35
36do_install () {
37 make DESTDIR=${D} install
38}
39
40COMPATIBLE_HOST = ".*-musl.*"