Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 1 | SUMMARY = "An HTTP library implementation in C" |
| 2 | DESCRIPTION = "libsoup is an HTTP client/server library for GNOME. It uses GObjects \ |
| 3 | and the glib main loop, to integrate well with GNOME applications." |
| 4 | HOMEPAGE = "https://wiki.gnome.org/Projects/libsoup" |
| 5 | BUGTRACKER = "https://bugzilla.gnome.org/" |
| 6 | SECTION = "x11/gnome/libs" |
| 7 | LICENSE = "LGPL-2.0-only" |
| 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2" |
| 9 | |
| 10 | DEPENDS = "glib-2.0 glib-2.0-native libxml2 sqlite3 libpsl nghttp2" |
| 11 | |
| 12 | SHRT_VER = "${@d.getVar('PV').split('.')[0]}.${@d.getVar('PV').split('.')[1]}" |
| 13 | |
| 14 | SRC_URI = "${GNOME_MIRROR}/libsoup/${SHRT_VER}/libsoup-${PV}.tar.xz" |
Patrick Williams | e760df8 | 2023-05-26 11:10:49 -0500 | [diff] [blame] | 15 | SRC_URI[sha256sum] = "78c8fa37cb152d40ec8c4a148d6155e2f6947f3f1602a7cda3a31ad40f5ee2f3" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 16 | |
| 17 | PROVIDES = "libsoup-3.0" |
| 18 | CVE_PRODUCT = "libsoup" |
| 19 | |
| 20 | S = "${WORKDIR}/libsoup-${PV}" |
| 21 | |
Patrick Williams | 2390b1b | 2022-11-03 13:47:49 -0500 | [diff] [blame] | 22 | inherit meson gettext pkgconfig upstream-version-is-even gobject-introspection gi-docgen |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 23 | |
| 24 | GIR_MESON_ENABLE_FLAG = 'enabled' |
| 25 | GIR_MESON_DISABLE_FLAG = 'disabled' |
| 26 | |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 27 | PACKAGECONFIG ??= "" |
Andrew Geissler | 5082cc7 | 2023-09-11 08:41:39 -0400 | [diff] [blame] | 28 | PACKAGECONFIG[brotli] = "-Dbrotli=enabled,-Dbrotli=disabled,brotli" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 29 | PACKAGECONFIG[gssapi] = "-Dgssapi=enabled,-Dgssapi=disabled,krb5" |
Andrew Geissler | 5082cc7 | 2023-09-11 08:41:39 -0400 | [diff] [blame] | 30 | PACKAGECONFIG[ntlm] = "-Dntlm=enabled,-Dntlm=disabled" |
| 31 | PACKAGECONFIG[sysprof] = "-Dsysprof=enabled,-Dsysprof=disabled,sysprof" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 32 | |
Andrew Geissler | 5082cc7 | 2023-09-11 08:41:39 -0400 | [diff] [blame] | 33 | # Tell libsoup where the target ntlm_auth is installed |
| 34 | do_write_config:append:class-target() { |
| 35 | cat >${WORKDIR}/soup.cross <<EOF |
| 36 | [binaries] |
| 37 | ntlm_auth = '${bindir}/ntlm_auth' |
| 38 | EOF |
| 39 | } |
| 40 | EXTRA_OEMESON += "--cross-file ${WORKDIR}/soup.cross" |
| 41 | |
| 42 | EXTRA_OEMESON += "-Dvapi=disabled -Dtls_check=false" |
| 43 | # Disable the test suites |
| 44 | EXTRA_OEMESON += "-Dtests=false -Dautobahn=disabled -Dpkcs11_tests=disabled" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 45 | |
Patrick Williams | 2390b1b | 2022-11-03 13:47:49 -0500 | [diff] [blame] | 46 | GIDOCGEN_MESON_OPTION = 'docs' |
| 47 | GIDOCGEN_MESON_ENABLE_FLAG = 'enabled' |
| 48 | GIDOCGEN_MESON_DISABLE_FLAG = 'disabled' |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 49 | |
| 50 | # When built without gnome support, libsoup will contain only one shared lib |
| 51 | # and will therefore become subject to renaming by debian.bbclass. Prevent |
| 52 | # renaming in order to keep the package name consistent regardless of whether |
| 53 | # gnome support is enabled or disabled. |
| 54 | DEBIAN_NOAUTONAME:${PN} = "1" |
| 55 | |
| 56 | # glib-networking is needed for SSL, proxies, etc. |
| 57 | RRECOMMENDS:${PN} = "glib-networking" |
| 58 | |
| 59 | BBCLASSEXTEND = "native nativesdk" |