Ivan Mikhaylov | 540b23d | 2020-06-30 19:47:53 +0300 | [diff] [blame] | 1 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" |
2 | |||||
3 | # Directory with new layer of source tree with additional files | ||||
4 | YAML_DIR = "xyz" | ||||
5 | |||||
6 | SRC_URI += "file://${YAML_DIR}" | ||||
7 | |||||
8 | S = "${WORKDIR}/git" | ||||
9 | |||||
10 | # Merge source tree by original project with our layer of additional files | ||||
11 | do_add_yamls(){ | ||||
12 | cp -r "${WORKDIR}/${YAML_DIR}" "${S}" | ||||
13 | } | ||||
14 | |||||
15 | addtask do_add_yamls after do_unpack before do_configure |