Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 1 | DESCRIPTION = "libftdi is a library to talk to FTDI chips.\ |
| 2 | FT232BM/245BM, FT2232C/D and FT232/245R using libusb,\ |
| 3 | including the popular bitbang mode." |
| 4 | HOMEPAGE = "http://www.intra2net.com/en/developer/libftdi/" |
| 5 | SECTION = "libs" |
| 6 | LICENSE = "LGPL-2.1-only & GPL-2.0-only" |
| 7 | LIC_FILES_CHKSUM= "\ |
| 8 | file://COPYING.GPL;md5=751419260aa954499f7abaabaa882bbe \ |
| 9 | file://COPYING.LIB;md5=5f30f0716dfdd0d91eb439ebec522ec2 \ |
| 10 | " |
| 11 | |
| 12 | DEPENDS = "libusb1 python3 swig-native" |
| 13 | |
| 14 | SRC_URI = "http://www.intra2net.com/en/developer/${BPN}/download/${BPN}1-${PV}.tar.bz2" |
| 15 | SRC_URI[sha256sum] = "7c7091e9c86196148bd41177b4590dccb1510bfe6cea5bf7407ff194482eb049" |
| 16 | |
| 17 | S = "${WORKDIR}/${BPN}1-${PV}" |
| 18 | |
| 19 | inherit cmake binconfig pkgconfig python3native |
| 20 | |
| 21 | PACKAGECONFIG ??= "" |
| 22 | PACKAGECONFIG[cpp-wrapper] = "-DFTDI_BUILD_CPP=on -DFTDIPP=on,-DFTDI_BUILD_CPP=off -DFTDIPP=off,boost" |
Patrick Williams | 8dd6848 | 2022-10-04 07:57:18 -0500 | [diff] [blame] | 23 | PACKAGECONFIG[ftdi-eeprom] = "-DFTDI_EEPROM=on,-DFTDI_EEPROM=off,libconfuse" |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 24 | |
Patrick Williams | 8dd6848 | 2022-10-04 07:57:18 -0500 | [diff] [blame] | 25 | EXTRA_OECMAKE = "-DSTATICLIBS=off -DEXAMPLES=off \ |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 26 | -DLIB_SUFFIX=${@d.getVar('baselib').replace('lib', '')} \ |
| 27 | -DPYTHON_LIBRARY=${STAGING_LIBDIR}/lib${PYTHON_DIR}${PYTHON_ABI}.so \ |
| 28 | -DPYTHON_INCLUDE_DIR=${STAGING_INCDIR}/${PYTHON_DIR}${PYTHON_ABI}" |
| 29 | |
| 30 | BBCLASSEXTEND = "native nativesdk" |
| 31 | |
Patrick Williams | 8dd6848 | 2022-10-04 07:57:18 -0500 | [diff] [blame] | 32 | PACKAGES =+ "${PN}-python ftdi-eeprom" |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 33 | |
Patrick Williams | 8dd6848 | 2022-10-04 07:57:18 -0500 | [diff] [blame] | 34 | FILES:ftdi-eeprom = "${bindir}/ftdi_eeprom" |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 35 | FILES:${PN}-python = "${libdir}/${PYTHON_DIR}/site-packages/" |