Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 1 | SUMMARY = "Python GObject bindings" |
| 2 | HOMEPAGE = "https://gitlab.gnome.org/GNOME/pygobject" |
| 3 | DESCRIPTION = "PyGObject is a Python package which provides bindings for GObject based libraries such as GTK, GStreamer, WebKitGTK, GLib, GIO and many more." |
| 4 | SECTION = "devel/python" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 5 | LICENSE = "LGPL-2.1-only" |
Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=a916467b91076e631dd8edb7424769c7" |
| 7 | |
| 8 | GNOMEBASEBUILDCLASS = "meson" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 9 | GIR_MESON_OPTION = "" |
| 10 | |
Patrick Williams | e760df8 | 2023-05-26 11:10:49 -0500 | [diff] [blame] | 11 | inherit gnomebase setuptools3-base gobject-introspection upstream-version-is-even features_check |
Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 12 | |
Patrick Williams | e760df8 | 2023-05-26 11:10:49 -0500 | [diff] [blame] | 13 | REQUIRED_DISTRO_FEATURES = "gobject-introspection-data" |
| 14 | |
| 15 | DEPENDS += "python3 glib-2.0" |
Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 16 | |
Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 17 | SRCNAME="pygobject" |
| 18 | |
| 19 | SRC_URI = " \ |
| 20 | http://ftp.gnome.org/pub/GNOME/sources/${SRCNAME}/${@gnome_verdir("${PV}")}/${SRCNAME}-${PV}.tar.xz \ |
| 21 | file://0001-Do-not-build-tests.patch \ |
| 22 | " |
Patrick Williams | 8e7b46e | 2023-05-01 14:19:06 -0500 | [diff] [blame] | 23 | SRC_URI[sha256sum] = "3c6805d1321be90cc32e648215a562430e0d3d6edcda8f4c5e7a9daffcad5710" |
Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 24 | |
| 25 | S = "${WORKDIR}/${SRCNAME}-${PV}" |
| 26 | |
| 27 | PACKAGECONFIG ??= "${@bb.utils.contains_any('DISTRO_FEATURES', [ 'directfb', 'wayland', 'x11' ], 'cairo', '', d)}" |
| 28 | |
Patrick Williams | e760df8 | 2023-05-26 11:10:49 -0500 | [diff] [blame] | 29 | RDEPENDS:${PN} += " \ |
| 30 | python3-io \ |
| 31 | python3-pkgutil \ |
| 32 | " |
Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 33 | |
| 34 | # python3-pycairo is checked on configuration -> DEPENDS |
| 35 | # we don't link against python3-pycairo -> RDEPENDS |
| 36 | PACKAGECONFIG[cairo] = "-Dpycairo=enabled,-Dpycairo=disabled, cairo python3-pycairo, python3-pycairo" |
| 37 | |
| 38 | BBCLASSEXTEND = "native" |
| 39 | PACKAGECONFIG:class-native = "" |