blob: f9a38116695db924290c7fec825dca76fbc45df5 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001# Copyright (C) 2022 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "API to access the kernel tracefs directory"
5HOMEPAGE = "https://git.kernel.org/pub/scm/libs/libtrace/libtracefs.git/"
6LICENSE = "GPL-2.0-or-later & LGPL-2.1-or-later"
7LIC_FILES_CHKSUM = "file://LICENSES/GPL-2.0;md5=e6a75371ba4d16749254a51215d13f97 \
8 file://LICENSES/LGPL-2.1;md5=b370887980db5dd40659b50909238dbd"
9SECTION = "libs"
10
Andrew Geissler8f840682023-07-21 09:09:43 -050011SRCREV = "dd148189b74da3e2f45c7e536319fec97cb71213"
Andrew Geissler517393d2023-01-13 08:55:19 -060012SRC_URI = "git://git.kernel.org/pub/scm/libs/libtrace/libtraceevent.git;branch=${BPN};protocol=https \
13 file://0001-makefile-Do-not-preserve-ownership-in-cp-command.patch"
14
15S = "${WORKDIR}/git"
16
Patrick Williamse760df82023-05-26 11:10:49 -050017export EXTRA_CFLAGS = "${CFLAGS}"
18
Andrew Geissler517393d2023-01-13 08:55:19 -060019inherit pkgconfig
20
21do_install() {
22 oe_runmake install DESTDIR=${D} pkgconfig_dir=${libdir}/pkgconfig
23}
24
25PACKAGES += "${PN}-plugins"
26
27FILES:${PN}-plugins += "${libdir}/traceevent/plugins"