blob: 45b3a96f1203dd6e8953b2dfcb9ddc9ce8d3e8a5 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "A multi-platform support library with a focus on asynchronous I/O"
2HOMEPAGE = "https://github.com/libuv/libuv"
3DESCRIPTION = "libuv is a multi-platform support library with a focus on asynchronous I/O. It was primarily developed for use by Node.js, but it's also used by Luvit, Julia, pyuv, and others."
4BUGTRACKER = "https://github.com/libuv/libuv/issues"
5LICENSE = "MIT"
Patrick Williamsb542dec2023-06-09 01:26:37 -05006LIC_FILES_CHKSUM = "file://LICENSE;md5=74b6f2f7818a4e3a80d03556f71b129b"
Andrew Geissler9aee5002022-03-30 16:27:02 +00007
Patrick Williamsb542dec2023-06-09 01:26:37 -05008SRCREV = "96e05543f53b19d9642b4b0dd73b86ad3cea313e"
9SRC_URI = "git://github.com/libuv/libuv.git;branch=master;protocol=https"
Andrew Geissler9aee5002022-03-30 16:27:02 +000010UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)"
11
12S = "${WORKDIR}/git"
13
14inherit autotools
15
16do_configure() {
17 ${S}/autogen.sh || bbnote "${PN} failed to autogen.sh"
18 oe_runconf
19}
20
21BBCLASSEXTEND = "native"