Patrick Williams | 520786c | 2023-06-25 16:20:36 -0500 | [diff] [blame] | 1 | # Copyright (C) 2017 - 2023 Armin Kuster <akuster808@gmail.com> |
| 2 | # Released under the MIT license (see COPYING.MIT for the terms) |
| 3 | |
| 4 | SUMARRY = "SCAP content for various platforms, upstream version" |
| 5 | HOME_URL = "https://www.open-scap.org/security-policies/scap-security-guide/" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=9bfa86579213cb4c6adaffface6b2820" |
| 7 | LICENSE = "BSD-3-Clause" |
| 8 | |
| 9 | SRCREV = "dad85502ce8da722a6afc391346c41cee61e90a9" |
| 10 | SRC_URI = "git://github.com/ComplianceAsCode/content.git;branch=master;protocol=https \ |
| 11 | file://0001-scap-security-guide-add-openembedded.patch \ |
| 12 | file://0001-standard.profile-expand-checks.patch \ |
| 13 | file://0001-scap-security-guide-add-Poky-support.patch \ |
| 14 | file://run_eval.sh \ |
| 15 | " |
| 16 | |
| 17 | |
| 18 | DEPENDS = "openscap-native python3-pyyaml-native python3-jinja2-native libxml2-native expat-native coreutils-native" |
| 19 | |
| 20 | S = "${WORKDIR}/git" |
| 21 | B = "${S}/build" |
| 22 | |
| 23 | inherit cmake pkgconfig python3native python3targetconfig |
| 24 | |
| 25 | OECMAKE_GENERATOR = "Unix Makefiles" |
| 26 | |
| 27 | EXTRA_OECMAKE += "-DENABLE_PYTHON_COVERAGE=OFF -DSSG_PRODUCT_DEFAULT=OFF -DSSG_PRODUCT_OE=ON" |
| 28 | |
| 29 | do_configure[depends] += "openscap-native:do_install" |
| 30 | |
| 31 | do_configure:prepend () { |
| 32 | sed -i -e 's:NAMES\ sed:NAMES\ ${HOSTTOOLS_DIR}/sed:g' ${S}/CMakeLists.txt |
| 33 | sed -i -e 's:NAMES\ grep:NAMES\ ${HOSTTOOLS_DIR}/grep:g' ${S}/CMakeLists.txt |
| 34 | } |
| 35 | |
| 36 | do_install:append() { |
| 37 | install -d ${D}${datadir}/openscap |
| 38 | install ${WORKDIR}/run_eval.sh ${D}${datadir}/openscap/. |
| 39 | } |
| 40 | |
| 41 | FILES:${PN} += "${datadir}/xml ${datadir}/openscap" |
| 42 | |
| 43 | RDEPENDS:${PN} = "openscap" |
| 44 | |
| 45 | COMPATIBLE_HOST:libc-musl = "null" |