Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | DESCRIPTION = "Xfce Menu Library" |
| 2 | SECTION = "x11/libs" |
| 3 | LICENSE = "LGPL-2.0-only" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=04a01abcbdabffae1ca26335a293276b" |
| 5 | DEPENDS = "xfce4-dev-tools-native libxfce4ui intltool-native" |
| 6 | |
| 7 | inherit xfce gtk-doc gobject-introspection features_check |
| 8 | |
| 9 | # xfce4 depends on libwnck3, gtk+3 and libepoxy need to be built with x11 PACKAGECONFIG. |
| 10 | # cairo would at least needed to be built with xlib. |
| 11 | ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}" |
| 12 | |
| 13 | SRC_URI += "file://0001-xfce-applications.menu-don-t-bloat-settings-menu-by-.patch" |
| 14 | SRC_URI[sha256sum] = "54633487566a8b8502b71c11a7f719efe27c069bd5773cc95f11ff4ea8f11a14" |
| 15 | |
| 16 | EXTRA_OECONF = "--disable-gtk-doc" |
| 17 | |
| 18 | do_compile:prepend() { |
| 19 | export GIR_EXTRA_LIBS_PATH="${B}/garcon/.libs" |
| 20 | } |
| 21 | |
| 22 | FILES:${PN} += "${datadir}/desktop-directories" |