Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame^] | 1 | SUMMARY = "open-source formatting library for C++" |
| 2 | DESCRIPTION = "{fmt} is an open-source formatting library for C++. It can be used as a safe and fast alternative to (s)printf and iostreams." |
| 3 | HOMEPAGE = "https://fmt.dev" |
| 4 | LICENSE = "MIT" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=af88d758f75f3c5c48a967501f24384b" |
| 6 | |
| 7 | SRC_URI = "git://github.com/fmtlib/fmt;branch=master;protocol=https" |
| 8 | SRCREV = "b6f4ceaed0a0a24ccf575fab6c56dd50ccf6f1a9" |
| 9 | |
| 10 | S = "${WORKDIR}/git" |
| 11 | |
| 12 | inherit cmake |
| 13 | inherit ptest |
| 14 | |
| 15 | EXTRA_OECMAKE += "-DBUILD_SHARED_LIBS=ON" |
| 16 | |
| 17 | BBCLASSEXTEND = "native nativesdk" |