blob: 496e900e7c683321ea7fd015610f9d405976cb3e [file] [log] [blame]
Joel Stanley34c894e2015-12-06 22:54:23 +10301SUMMARY = "pflash programmer for OpenPower"
2DESCRIPTION = "pflash firmware programming tool for OpenPower machines"
3HOMEPAGE = "https://github.com/open-power"
4LICENSE = "Apache-2.0"
5
6SRC_URI += "git://github.com/open-power/skiboot.git"
Brad Bishopf64e73c2016-06-08 23:06:31 -04007
8SRC_URI += "file://0001-Make-links-target-reusable.patch"
9SRC_URI += "file://0002-external-Remove-external-shared-link-targets.patch"
10SRC_URI += "file://0003-external-Fix-pflash-install-target.patch"
11SRC_URI += "file://0004-external-Remove-m64-from-shared-CFLAGS-on-ARM.patch"
12SRC_URI += "file://0005-external-Create-shared-rules.mk.patch"
13SRC_URI += "file://0006-external-Add-dynamically-linked-pflash.patch"
14
Joel Stanley34c894e2015-12-06 22:54:23 +103015LIC_FILES_CHKSUM = "file://${S}/LICENCE;md5=3b83ef96387f14655fc854ddc3c6bd57"
16
Brad Bishopf64e73c2016-06-08 23:06:31 -040017SRCREV = "skiboot-5.2.2"
18PV = "5.2.2"
Joel Stanley34c894e2015-12-06 22:54:23 +103019
20S = "${WORKDIR}/git"
21
22EXTRA_OEMAKE = 'CROSS_COMPILE=${TARGET_PREFIX} PFLASH_VERSION=${PV} V=1'
23
24do_compile () {
Brad Bishopf64e73c2016-06-08 23:06:31 -040025 oe_runmake -C external/pflash all LINKAGE=dynamic
Joel Stanley34c894e2015-12-06 22:54:23 +103026}
27
28do_install () {
Brad Bishopf64e73c2016-06-08 23:06:31 -040029 oe_runmake -C external/pflash install LINKAGE=dynamic DESTDIR=${D} PREFIX=${D}/usr
Joel Stanley34c894e2015-12-06 22:54:23 +103030}
Brad Bishopf64e73c2016-06-08 23:06:31 -040031
32BBCLASSEXTEND = "native nativesdk"