Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "User support binary for the uvesafb kernel module" |
| 2 | HOMEPAGE = "http://dev.gentoo.org/~spock/projects/uvesafb/" |
| 3 | |
| 4 | # the copyright info is at the bottom of README, expect break |
| 5 | LICENSE = "GPLv2" |
| 6 | LIC_FILES_CHKSUM = "file://README;md5=94ac1971e4f2309dc322d598e7b1f7dd" |
| 7 | |
| 8 | DEPENDS = "virtual/kernel" |
| 9 | RRECOMMENDS_${PN} = "kernel-module-uvesafb" |
| 10 | PR = "r2" |
| 11 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 12 | SRC_URI = "http://snapshot.debian.org/archive/debian/20110427T035506Z/pool/main/v/${BPN}/${BPN}_${PV}.orig.tar.gz \ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 13 | file://Update-x86emu-from-X.org.patch \ |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 14 | file://ar-from-env.patch \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 15 | file://Support-for-cross-compilation.patch \ |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 16 | " |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 17 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 18 | SRC_URI[md5sum] = "889686ec8424468fe0d205742e77a4c2" |
| 19 | SRC_URI[sha256sum] = "93575c82e4307d8c4c370ec6b767f5cf87e527b2378146d652a6d8e25d5bdbc5" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 20 | |
| 21 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
| 22 | COMPATIBLE_HOST = '(i.86|x86_64).*-linux' |
| 23 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 24 | do_configure () { |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 25 | TARGET_ARCH="${TARGET_ARCH}" ./configure --with-x86emu |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 26 | } |
| 27 | |
| 28 | do_compile () { |
| 29 | KDIR="${STAGING_DIR_HOST}/usr" make |
| 30 | } |
| 31 | |
| 32 | do_install () { |
| 33 | install -d ${D}${base_sbindir} |
| 34 | install v86d ${D}${base_sbindir}/ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 35 | } |