Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 1 | # Helper class to pull in the right gtk-doc dependencies and configure |
| 2 | # gtk-doc to enable or disable documentation building (which requries the |
| 3 | # use of usermode qemu). |
| 4 | |
| 5 | # This variable is set to True if api-documentation is in |
| 6 | # DISTRO_FEATURES and qemu-usermode is in MACHINE_FEATURES, and False otherwise. |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 7 | # |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 8 | # It should be used in recipes to determine whether gtk-doc based documentation should be built, |
| 9 | # so that qemu use can be avoided when necessary. |
| 10 | GTKDOC_ENABLED ?= "${@bb.utils.contains('DISTRO_FEATURES', 'api-documentation', \ |
| 11 | bb.utils.contains('MACHINE_FEATURES', 'qemu-usermode', 'True', 'False', d), 'False', d)}" |
| 12 | |
| 13 | EXTRA_OECONF_prepend_class-target = "${@bb.utils.contains('GTKDOC_ENABLED', 'True', '--enable-gtk-doc --enable-gtk-doc-html --disable-gtk-doc-pdf', \ |
| 14 | '--disable-gtk-doc', d)} " |
| 15 | |
| 16 | # When building native recipes, disable gtkdoc, as it is not necessary, |
| 17 | # pulls in additional dependencies, and makes build times longer |
| 18 | EXTRA_OECONF_prepend_class-native = "--disable-gtk-doc " |
| 19 | EXTRA_OECONF_prepend_class-nativesdk = "--disable-gtk-doc " |
| 20 | |
| 21 | DEPENDS_append_class-target = " gtk-doc-native qemu-native" |
| 22 | |
| 23 | # Even though gtkdoc is disabled on -native, gtk-doc package is still |
| 24 | # needed for m4 macros. |
| 25 | DEPENDS_append_class-native = " gtk-doc-native" |
| 26 | DEPENDS_append_class-nativesdk = " gtk-doc-native" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 27 | |
| 28 | # The documentation directory, where the infrastructure will be copied. |
| 29 | # gtkdocize has a default of "." so to handle out-of-tree builds set this to $S. |
| 30 | GTKDOC_DOCDIR ?= "${S}" |
| 31 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 32 | do_configure_prepend () { |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 33 | ( cd ${S}; gtkdocize --docdir ${GTKDOC_DOCDIR} || true ) |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 34 | } |
| 35 | |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 36 | inherit qemu |
| 37 | |
| 38 | export STAGING_DIR_HOST |
| 39 | |
| 40 | do_compile_prepend_class-target () { |
| 41 | |
| 42 | # Write out a qemu wrapper that will be given to gtkdoc-scangobj so that it |
| 43 | # can run target helper binaries through that. |
| 44 | qemu_binary="${@qemu_wrapper_cmdline(d, '$STAGING_DIR_HOST', ['\$GIR_EXTRA_LIBS_PATH','$STAGING_DIR_HOST/${libdir}','$STAGING_DIR_HOST/${base_libdir}'])}" |
| 45 | cat > ${B}/gtkdoc-qemuwrapper << EOF |
| 46 | #!/bin/sh |
| 47 | # Use a modules directory which doesn't exist so we don't load random things |
| 48 | # which may then get deleted (or their dependencies) and potentially segfault |
| 49 | export GIO_MODULE_DIR=${STAGING_LIBDIR}/gio/modules-dummy |
| 50 | |
| 51 | GIR_EXTRA_LIBS_PATH=\`find ${B} -name .libs| tr '\n' ':'\`\$GIR_EXTRA_LIBS_PATH |
| 52 | |
| 53 | if test -d ".libs"; then |
| 54 | $qemu_binary ".libs/\$@" |
| 55 | else |
| 56 | $qemu_binary "\$@" |
| 57 | fi |
| 58 | |
| 59 | if [ \$? -ne 0 ]; then |
| 60 | echo "If the above error message is about missing .so libraries, then setting up GIR_EXTRA_LIBS_PATH in the recipe should help." |
| 61 | echo "(typically like this: GIR_EXTRA_LIBS_PATH=\"$""{B}/something/.libs\" )" |
| 62 | exit 1 |
| 63 | fi |
| 64 | EOF |
| 65 | chmod +x ${B}/gtkdoc-qemuwrapper |
| 66 | } |
| 67 | |
| 68 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 69 | inherit pkgconfig |