Matt Spinler | 1e7bfcc | 2017-03-06 11:06:27 -0600 | [diff] [blame] | 1 | SUMMARY = "Enables reboots on host failures" |
| 2 | DESCRIPTION = "Manages the settings entry that controls reboots \ |
| 3 | on host failures" |
| 4 | PR = "r1" |
Brad Bishop | 75f0387 | 2018-11-03 09:41:57 -0700 | [diff] [blame] | 5 | LICENSE = "Apache-2.0" |
| 6 | LIC_FILES_CHKSUM = "file://${PHOSPHORBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658" |
Matt Spinler | 1e7bfcc | 2017-03-06 11:06:27 -0600 | [diff] [blame] | 7 | |
| 8 | inherit obmc-phosphor-systemd |
Matt Spinler | 1e7bfcc | 2017-03-06 11:06:27 -0600 | [diff] [blame] | 9 | |
Matt Spinler | ab0a927 | 2017-03-15 16:42:54 -0500 | [diff] [blame] | 10 | TMPL = "host-failure-reboots@.service" |
| 11 | INSTFMT = "host-failure-reboots@{0}.service" |
| 12 | LINK_FMT = "${TMPL}:${INSTFMT}" |
| 13 | |
| 14 | SYSTEMD_SERVICE_${PN} += "${TMPL}" |
| 15 | SYSTEMD_LINK_${PN} += "${@compose_list(d, 'LINK_FMT', 'OBMC_HOST_INSTANCES')}" |