Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Tool to produce a statistics based on a diff" |
| 2 | DESCRIPTION = "diffstat reads the output of diff and displays a histogram of \ |
| 3 | the insertions, deletions, and modifications per-file. It is useful for \ |
| 4 | reviewing large, complex patch files." |
| 5 | HOMEPAGE = "http://invisible-island.net/diffstat/" |
| 6 | SECTION = "devel" |
| 7 | LICENSE = "MIT" |
Andrew Geissler | c723b72 | 2021-01-08 16:14:09 -0600 | [diff] [blame] | 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=a3d0bb117493e804b0c1a868ddf23321" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 9 | |
| 10 | SRC_URI = "http://invisible-mirror.net/archives/${BPN}/${BP}.tgz \ |
| 11 | file://run-ptest \ |
| 12 | file://avoid-check-user-break-cc.patch \ |
| 13 | file://0001-aclocal.m4-add-missing-header-defines.patch \ |
| 14 | " |
| 15 | |
| 16 | SRC_URI[md5sum] = "b9272ec8af6257103261ec3622692991" |
| 17 | SRC_URI[sha256sum] = "7eddd53401b99b90bac3f7ebf23dd583d7d99c6106e67a4f1161b7a20110dc6f" |
| 18 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 19 | inherit autotools gettext ptest |
| 20 | |
| 21 | EXTRA_AUTORECONF += "--exclude=aclocal" |
| 22 | |
| 23 | LDFLAGS += "${TOOLCHAIN_OPTIONS}" |
| 24 | |
| 25 | do_install_ptest() { |
| 26 | cp -r ${S}/testing ${D}${PTEST_PATH} |
| 27 | } |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 28 | |
| 29 | BBCLASSEXTEND = "nativesdk" |