Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 1 | require vim.inc |
| 2 | |
| 3 | PROVIDES = "xxd" |
| 4 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 5 | RDEPENDS:${PN} = "ncurses-terminfo-base" |
| 6 | # Recommend that runtime data is installed along with vim |
| 7 | RRECOMMENDS:${PN} = "${PN}-syntax ${PN}-help ${PN}-tutor ${PN}-vimrc ${PN}-common" |
| 8 | |
| 9 | PACKAGECONFIG:class-native = "" |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 10 | BBCLASSEXTEND = "native nativesdk" |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 11 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 12 | ALTERNATIVE:${PN}:append = " xxd" |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 13 | ALTERNATIVE_TARGET[xxd] = "${bindir}/xxd" |
| 14 | ALTERNATIVE_LINK_NAME[xxd] = "${bindir}/xxd" |
Andrew Geissler | 5a43b43 | 2020-06-13 10:46:56 -0500 | [diff] [blame] | 15 | |
| 16 | # We override the default in security_flags.inc because vim (not vim-tiny!) will abort |
| 17 | # in many places for _FORTIFY_SOURCE=2. Security flags become part of CC. |
| 18 | # |
| 19 | lcl_maybe_fortify = "${@oe.utils.conditional('DEBUG_BUILD','1','','-D_FORTIFY_SOURCE=1',d)}" |