Deepak Kodihalli | f98bd11 | 2017-03-24 07:44:16 -0500 | [diff] [blame] | 1 | SUMMARY = "OpenPOWER OCC controller" |
| 2 | DESCRIPTION = "Application to contol the OpenPOWER On-Chip-Controller" |
| 3 | HOMEPAGE = "https://github.com/openbmc/openpower-occ-control" |
| 4 | PR = "r1" |
| 5 | |
Deepak Kodihalli | 615bdc1 | 2017-04-06 23:50:34 -0500 | [diff] [blame] | 6 | inherit autotools \ |
| 7 | pkgconfig \ |
Vishwanatha Subbanna | 359eee8 | 2017-05-04 09:45:29 -0500 | [diff] [blame] | 8 | obmc-phosphor-dbus-service \ |
| 9 | pythonnative |
Deepak Kodihalli | f98bd11 | 2017-03-24 07:44:16 -0500 | [diff] [blame] | 10 | |
| 11 | require ${PN}.inc |
| 12 | |
Andrew Geissler | 4cd9d0a | 2017-08-15 14:04:51 -0500 | [diff] [blame] | 13 | SRC_URI += "file://occ-active.sh" |
| 14 | do_install_append() { |
| 15 | install -d ${D}${bindir} |
| 16 | install -m 0755 ${WORKDIR}/occ-active.sh \ |
| 17 | ${D}${bindir}/occ-active.sh |
| 18 | } |
| 19 | |
Vishwanatha Subbanna | 5f74f13 | 2017-07-07 02:55:58 -0500 | [diff] [blame] | 20 | DBUS_SERVICE_${PN} += "org.open_power.OCC.Control.service" |
Andrew Geissler | 4cd9d0a | 2017-08-15 14:04:51 -0500 | [diff] [blame] | 21 | SYSTEMD_SERVICE_${PN} += "op-occ-disable@.service" |
Deepak Kodihalli | f98bd11 | 2017-03-24 07:44:16 -0500 | [diff] [blame] | 22 | |
Vishwanatha Subbanna | fcf5076 | 2017-08-09 15:00:34 +0530 | [diff] [blame] | 23 | DEPENDS += "virtual/${PN}-config-native" |
Deepak Kodihalli | f98bd11 | 2017-03-24 07:44:16 -0500 | [diff] [blame] | 24 | DEPENDS += " \ |
| 25 | sdbusplus \ |
| 26 | sdbusplus-native \ |
| 27 | phosphor-logging \ |
| 28 | openpower-dbus-interfaces \ |
Vishwanatha Subbanna | 5f74f13 | 2017-07-07 02:55:58 -0500 | [diff] [blame] | 29 | phosphor-dbus-interfaces \ |
Deepak Kodihalli | f98bd11 | 2017-03-24 07:44:16 -0500 | [diff] [blame] | 30 | openpower-dbus-interfaces-native \ |
| 31 | autoconf-archive-native \ |
Andrew Geissler | 4cd9d0a | 2017-08-15 14:04:51 -0500 | [diff] [blame] | 32 | obmc-targets \ |
| 33 | systemd \ |
Deepak Kodihalli | f98bd11 | 2017-03-24 07:44:16 -0500 | [diff] [blame] | 34 | " |
| 35 | |
| 36 | RDEPENDS_${PN} += " \ |
| 37 | sdbusplus \ |
| 38 | phosphor-logging \ |
| 39 | openpower-dbus-interfaces \ |
Vishwanatha Subbanna | 5f74f13 | 2017-07-07 02:55:58 -0500 | [diff] [blame] | 40 | phosphor-dbus-interfaces \ |
Deepak Kodihalli | f98bd11 | 2017-03-24 07:44:16 -0500 | [diff] [blame] | 41 | " |
| 42 | |
Vishwanatha Subbanna | fcf5076 | 2017-08-09 15:00:34 +0530 | [diff] [blame] | 43 | EXTRA_OECONF = "YAML_PATH=${STAGING_DATADIR_NATIVE}/${PN}" |
Lei YU | 80caf06 | 2017-07-20 15:25:28 +0800 | [diff] [blame] | 44 | EXTRA_OECONF_append = "${@bb.utils.contains('OBMC_MACHINE_FEATURES', 'i2c-occ', ' --enable-i2c-occ', '', d)}" |
| 45 | |
Andrew Geissler | 4cd9d0a | 2017-08-15 14:04:51 -0500 | [diff] [blame] | 46 | # Ensure host stop target requires occ disable service |
| 47 | OCC_DISABLE_TMPL = "op-occ-disable@.service" |
| 48 | HOST_STOP_TGTFMT = "obmc-host-stop@{0}.target" |
| 49 | OCC_DISABLE_INSTFMT = "op-occ-disable@{0}.service" |
| 50 | HOST_STOP_OCC_DISABLE_FMT = "../${OCC_DISABLE_TMPL}:${HOST_STOP_TGTFMT}.requires/${OCC_DISABLE_INSTFMT}" |
| 51 | SYSTEMD_LINK_${PN} += "${@compose_list_zip(d, 'HOST_STOP_OCC_DISABLE_FMT', 'OBMC_HOST_INSTANCES')}" |
| 52 | |
Deepak Kodihalli | f98bd11 | 2017-03-24 07:44:16 -0500 | [diff] [blame] | 53 | S = "${WORKDIR}/git" |