Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | SUMMARY = "Password strength checker library" |
| 2 | HOMEPAGE = "https://github.com/cracklib/cracklib" |
| 3 | DESCRIPTION = "${SUMMARY}" |
| 4 | |
| 5 | LICENSE = "LGPLv2.1+" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=e3eda01d9815f8d24aae2dbd89b68b06" |
| 7 | |
| 8 | DEPENDS = "cracklib-native zlib" |
| 9 | |
| 10 | EXTRA_OECONF = "--without-python --libdir=${base_libdir}" |
| 11 | |
| 12 | SRC_URI = "git://github.com/cracklib/cracklib;protocol=https;branch=master \ |
| 13 | file://0001-packlib.c-support-dictionary-byte-order-dependent.patch \ |
| 14 | file://0002-craklib-fix-testnum-and-teststr-failed.patch" |
| 15 | |
| 16 | SRCREV = "f83934cf3cced0c9600c7d81332f4169f122a2cf" |
| 17 | S = "${WORKDIR}/git/src" |
| 18 | |
| 19 | inherit autotools gettext |
| 20 | |
| 21 | # This is custom stuff from upstream's autogen.sh |
| 22 | do_configure:prepend() { |
| 23 | mkdir -p ${S}/m4 |
| 24 | echo EXTRA_DIST = *.m4 > ${S}/m4/Makefile.am |
| 25 | touch ${S}/ABOUT-NLS |
| 26 | } |
| 27 | |
| 28 | do_install:append:class-target() { |
| 29 | create-cracklib-dict -o ${D}${datadir}/cracklib/pw_dict ${D}${datadir}/cracklib/cracklib-small |
| 30 | } |
| 31 | |
| 32 | BBCLASSEXTEND = "native nativesdk" |
| 33 | |