Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | SUMMARY = "A library for text mode user interfaces" |
| 2 | |
| 3 | DESCRIPTION = "Newt is a programming library for color text mode, widget based user \ |
| 4 | interfaces. Newt can be used to add stacked windows, entry widgets, \ |
| 5 | checkboxes, radio buttons, labels, plain text fields, scrollbars, \ |
| 6 | etc., to text mode user interfaces. This package also contains the \ |
| 7 | shared library needed by programs built with newt, as well as a \ |
| 8 | /usr/bin/dialog replacement called whiptail. Newt is based on the \ |
| 9 | slang library." |
| 10 | |
| 11 | HOMEPAGE = "https://releases.pagure.org/newt/" |
| 12 | SECTION = "libs" |
| 13 | |
| 14 | LICENSE = "LGPLv2" |
| 15 | LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2" |
| 16 | |
| 17 | # slang needs to be >= 2.2 |
Brad Bishop | f3fd288 | 2019-06-21 08:06:37 -0400 | [diff] [blame] | 18 | DEPENDS = "slang popt python3" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 19 | |
| 20 | SRC_URI = "https://releases.pagure.org/newt/newt-${PV}.tar.gz \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 21 | file://cross_ar.patch \ |
| 22 | file://Makefile.in-Add-tinfo-library-to-the-linking-librari.patch \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 23 | file://0001-detect-gold-as-GNU-linker-too.patch \ |
Andrew Geissler | c182c62 | 2020-05-15 14:13:32 -0500 | [diff] [blame] | 24 | file://0002-don-t-ignore-CFLAGS-when-building-snack.patch \ |
| 25 | " |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 26 | |
Brad Bishop | 08902b0 | 2019-08-20 09:16:51 -0400 | [diff] [blame] | 27 | SRC_URI[md5sum] = "a0a5fd6b53bb167a65e15996b249ebb5" |
| 28 | SRC_URI[sha256sum] = "265eb46b55d7eaeb887fca7a1d51fe115658882dfe148164b6c49fccac5abb31" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 29 | |
| 30 | S = "${WORKDIR}/newt-${PV}" |
| 31 | |
Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 32 | inherit autotools-brokensep python3native python3-dir python3targetconfig |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 33 | |
Brad Bishop | f3fd288 | 2019-06-21 08:06:37 -0400 | [diff] [blame] | 34 | EXTRA_OECONF = "--without-tcl --with-python" |
| 35 | |
| 36 | EXTRA_OEMAKE += "PYTHONVERS=${PYTHON_DIR}" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 37 | |
| 38 | CLEANBROKEN = "1" |
| 39 | |
| 40 | export CPPFLAGS |
| 41 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 42 | PACKAGES:prepend = "whiptail ${PN}-python " |
Brad Bishop | f3fd288 | 2019-06-21 08:06:37 -0400 | [diff] [blame] | 43 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 44 | RDEPENDS:${PN}-python += "python3-core" |
| 45 | FILES:${PN}-python = "${PYTHON_SITEPACKAGES_DIR}/*" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 46 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 47 | do_configure:prepend() { |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 48 | sh autogen.sh |
| 49 | } |
| 50 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 51 | do_compile:prepend() { |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 52 | # Make sure the recompile is OK |
| 53 | rm -f ${B}/.depend |
| 54 | } |
| 55 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 56 | FILES:whiptail = "${bindir}/whiptail" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 57 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 58 | BBCLASSEXTEND = "native nativesdk" |