Brad Bishop | e327803 | 2016-11-09 20:43:11 -0500 | [diff] [blame] | 1 | SUMMARY = "C++ bindings for systemd dbus APIs" |
| 2 | DESCRIPTION = "C++ bindings for systemd dbus APIs." |
Brad Bishop | e327803 | 2016-11-09 20:43:11 -0500 | [diff] [blame] | 3 | |
| 4 | inherit autotools pkgconfig |
Patrick Williams | 8fc9629 | 2016-11-22 07:01:14 -0600 | [diff] [blame] | 5 | inherit obmc-phosphor-python-autotools |
Brad Bishop | e327803 | 2016-11-09 20:43:11 -0500 | [diff] [blame] | 6 | |
Patrick Williams | 2e59532 | 2020-03-31 12:51:05 -0500 | [diff] [blame^] | 7 | include sdbusplus-rev.inc |
| 8 | |
Nagaraju Goruganti | 9940d4f | 2017-08-22 05:24:26 -0500 | [diff] [blame] | 9 | DEPENDS += " \ |
| 10 | autoconf-archive-native \ |
Patrick Williams | 853ff1b | 2020-02-24 16:27:10 -0600 | [diff] [blame] | 11 | ${PYTHON_PN}-inflection-native \ |
| 12 | ${PYTHON_PN}-mako-native \ |
| 13 | ${PYTHON_PN}-pyyaml-native \ |
Nagaraju Goruganti | 9940d4f | 2017-08-22 05:24:26 -0500 | [diff] [blame] | 14 | " |
Brad Bishop | 13b8afa | 2017-01-12 14:06:43 -0500 | [diff] [blame] | 15 | RDEPENDS_sdbus++ += " \ |
Patrick Williams | 853ff1b | 2020-02-24 16:27:10 -0600 | [diff] [blame] | 16 | ${PYTHON_PN} \ |
| 17 | ${PYTHON_PN}-inflection \ |
| 18 | ${PYTHON_PN}-mako \ |
| 19 | ${PYTHON_PN}-pyyaml \ |
Brad Bishop | e327803 | 2016-11-09 20:43:11 -0500 | [diff] [blame] | 20 | " |
| 21 | |
Brad Bishop | 6b4da62 | 2017-01-18 13:59:33 -0500 | [diff] [blame] | 22 | # sdbus++ has a handful of runtime dependencies on other python packages. |
| 23 | # Bitbake doesn't do anything with RDEPENDS in native context because |
| 24 | # native context doesn't have packages. |
| 25 | # |
| 26 | # While technically sdbus++ doesn't require its runtime dependencies to be |
| 27 | # installed to build, work around the above native context behavior |
| 28 | # by adding a build dependency so that clients don't have to DEPEND |
| 29 | # on sdbus++ runtime dependencies manually. |
| 30 | |
| 31 | DEPENDS_append_class-native = " \ |
Patrick Williams | 853ff1b | 2020-02-24 16:27:10 -0600 | [diff] [blame] | 32 | ${PYTHON_PN}-inflection-native \ |
| 33 | ${PYTHON_PN}-mako-native \ |
| 34 | ${PYTHON_PN}-pyyaml-native \ |
Brad Bishop | 6b4da62 | 2017-01-18 13:59:33 -0500 | [diff] [blame] | 35 | " |
| 36 | |
Adriana Kobylak | 9bcfdbb | 2017-02-12 17:40:26 -0600 | [diff] [blame] | 37 | PACKAGECONFIG ??= "libsdbusplus transaction" |
Brad Bishop | e327803 | 2016-11-09 20:43:11 -0500 | [diff] [blame] | 38 | PACKAGECONFIG[libsdbusplus] = "--enable-libsdbusplus,--disable-libsdbusplus,systemd,libsystemd" |
Adriana Kobylak | 9bcfdbb | 2017-02-12 17:40:26 -0600 | [diff] [blame] | 39 | PACKAGECONFIG[transaction] = "--enable-transaction,--disable-transaction" |
Brad Bishop | e327803 | 2016-11-09 20:43:11 -0500 | [diff] [blame] | 40 | |
Patrick Williams | 592d798 | 2016-11-22 11:05:11 -0600 | [diff] [blame] | 41 | PROVIDES_prepend = "sdbus++ " |
Brad Bishop | 50a5dc1 | 2018-02-27 00:30:06 -0500 | [diff] [blame] | 42 | PACKAGE_BEFORE_PN = "sdbus++" |
Patrick Williams | 592d798 | 2016-11-22 11:05:11 -0600 | [diff] [blame] | 43 | FILES_sdbus++_append = " ${bindir}/sdbus++" |
| 44 | PYTHON_AUTOTOOLS_PACKAGE = "sdbus++" |
| 45 | |
Brad Bishop | e327803 | 2016-11-09 20:43:11 -0500 | [diff] [blame] | 46 | PACKAGECONFIG_remove_class-native = "libsdbusplus" |
| 47 | PACKAGECONFIG_remove_class-nativesdk = "libsdbusplus" |
| 48 | |
Brad Bishop | e327803 | 2016-11-09 20:43:11 -0500 | [diff] [blame] | 49 | BBCLASSEXTEND += "native nativesdk" |