blob: d3f7525dc9840511d9027d074ec827489bab2a2e [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001DESCRIPTION = "This is a simple example recipe that cross-compiles a Go program."
2SECTION = "examples"
3HOMEPAGE = "https://golang.org/"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05004
Brad Bishopd7bf8c12018-02-25 22:55:05 -05005LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05007
Brad Bishopd7bf8c12018-02-25 22:55:05 -05008SRC_URI = "git://${GO_IMPORT}"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06009SRCREV = "bcf50bfd7dcd8020c90965747d857ae42802e0c5"
Brad Bishop316dfdd2018-06-25 12:45:53 -040010UPSTREAM_CHECK_COMMITS = "1"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050011
Brad Bishopd7bf8c12018-02-25 22:55:05 -050012GO_IMPORT = "github.com/golang/example"
13GO_INSTALL = "${GO_IMPORT}/hello"
Andrew Geissler90fd73c2021-03-05 15:25:55 -060014GO_WORKDIR = "${GO_INSTALL}"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050015
Andrew Geissler90fd73c2021-03-05 15:25:55 -060016inherit go-mod
Brad Bishopd7bf8c12018-02-25 22:55:05 -050017
18# This is just to make clear where this example is
19do_install_append() {
20 mv ${D}${bindir}/hello ${D}${bindir}/${BPN}
Brad Bishop6e60e8b2018-02-01 10:27:11 -050021}