Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame^] | 1 | SUMMARY = "A MutableSet that remembers its order, so that every entry has an index." |
| 2 | HOMEPAGE = "http://github.com/LuminosoInsight/ordered-set" |
| 3 | LICENSE = "MIT" |
| 4 | LIC_FILES_CHKSUM = "file://MIT-LICENSE;md5=3bf5e1ad64c0d99032c3143361fa234e" |
| 5 | |
| 6 | SRC_URI[sha256sum] = "694a8e44c87657c59292ede72891eb91d34131f6531463aab3009191c77364a8" |
| 7 | |
| 8 | inherit pypi setuptools3 ptest |
| 9 | |
| 10 | DEPENDS += "python3-pytest-runner-native" |
| 11 | |
| 12 | SRC_URI += " \ |
| 13 | file://run-ptest \ |
| 14 | " |
| 15 | |
| 16 | RDEPENDS:${PN}-ptest += " \ |
| 17 | ${PYTHON_PN}-pytest \ |
| 18 | " |
| 19 | |
| 20 | do_install_ptest() { |
| 21 | cp -f ${S}/test/test_ordered_set.py ${D}${PTEST_PATH}/ |
| 22 | } |