Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | SUMMARY = "Seamless operability between C++11 and Python" |
| 2 | HOMEPAGE = "https://github.com/wjakob/pybind11" |
| 3 | LICENSE = "BSD-2-Clause" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=774f65abd8a7fe3124be2cdf766cd06f" |
| 5 | |
| 6 | DEPENDS = "boost" |
| 7 | |
| 8 | SRC_URI = "git://github.com/pybind/pybind11.git;branch=master;protocol=https \ |
| 9 | file://0001-Do-not-strip-binaries.patch \ |
| 10 | file://0001-Do-not-check-pointer-size-when-cross-compiling.patch \ |
| 11 | " |
| 12 | SRCREV = "f7b499615e14d70ab098a20deb0cdb3889998a1a" |
| 13 | |
| 14 | S = "${WORKDIR}/git" |
| 15 | |
| 16 | BBCLASSEXTEND = "native" |
| 17 | |
| 18 | EXTRA_OECMAKE = "-DPYBIND11_TEST=OFF" |
| 19 | |
| 20 | inherit cmake setuptools3 python3native |
| 21 | |
| 22 | do_configure() { |
| 23 | cmake_do_configure |
| 24 | } |
| 25 | |
| 26 | do_compile() { |
| 27 | setuptools3_do_compile |
| 28 | cmake_do_compile |
| 29 | } |
| 30 | |
| 31 | do_install() { |
| 32 | setuptools3_do_install |
| 33 | cmake_do_install |
| 34 | } |
| 35 | |
| 36 | BBCLASSEXTEND = "native nativesdk" |