Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame^] | 1 | SUMMARY = "Extensible memoizing collections and decorators" |
| 2 | HOMEPAGE = "https://github.com/tkem/cachetools" |
| 3 | DESCRIPTION = "This module provides various memoizing \ |
| 4 | collections and decorators, including variants of the \ |
| 5 | Python 3 Standard Library @lru_cache function decorator." |
| 6 | SECTION = "devel/python" |
| 7 | |
| 8 | LICENSE = "MIT" |
| 9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=439a07e400525964c3c82684146e46eb" |
| 10 | |
| 11 | inherit pypi python_setuptools_build_meta ptest |
| 12 | |
| 13 | SRC_URI += " \ |
| 14 | file://run-ptest \ |
| 15 | " |
| 16 | |
| 17 | RDEPENDS:${PN} += " \ |
| 18 | ${PYTHON_PN}-math \ |
| 19 | " |
| 20 | |
| 21 | RDEPENDS:${PN}-ptest += " \ |
| 22 | ${PYTHON_PN}-pytest \ |
| 23 | " |
| 24 | |
| 25 | do_install_ptest() { |
| 26 | install -d ${D}${PTEST_PATH}/tests |
| 27 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| 28 | } |
| 29 | |
| 30 | SRC_URI[sha256sum] = "486471dfa8799eb7ec503a8059e263db000cdda20075ce5e48903087f79d5fd6" |
| 31 | |
| 32 | BBCLASSEXTEND = "native nativesdk" |