Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "A library for bits of crypto UI and parsing etc" |
| 2 | DESCRIPTION = "GCR is a library for displaying certificates, and crypto UI, \ |
| 3 | accessing key stores. It also provides the viewer for crypto files on the \ |
| 4 | GNOME desktop." |
| 5 | HOMEPAGE = "https://gitlab.gnome.org/GNOME/gcr" |
| 6 | BUGTRACKER = "https://gitlab.gnome.org/GNOME/gcr/issues" |
| 7 | |
| 8 | LICENSE = "GPL-2.0-only" |
| 9 | LIC_FILES_CHKSUM = "file://COPYING;md5=55ca817ccb7d5b5b66355690e9abc605" |
| 10 | |
| 11 | DEPENDS = "p11-kit glib-2.0 libgcrypt gnupg-native \ |
| 12 | ${@bb.utils.contains('GI_DATA_ENABLED', 'True', 'libxslt-native', '', d)}" |
| 13 | |
| 14 | CACHED_CONFIGUREVARS += "ac_cv_path_GPG='gpg2'" |
| 15 | |
| 16 | CFLAGS += "-D_GNU_SOURCE" |
| 17 | |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 18 | GTKDOC_MESON_OPTION = "gtk_doc" |
Andrew Geissler | 3eeda90 | 2023-05-19 10:14:02 -0500 | [diff] [blame] | 19 | inherit gnomebase gtk-icon-cache gi-docgen features_check vala gobject-introspection gettext mime mime-xdg |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 20 | |
| 21 | REQUIRED_DISTRO_FEATURES = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'opengl', '', d)}" |
| 22 | |
Patrick Williams | 3965356 | 2024-03-01 08:54:02 -0600 | [diff] [blame] | 23 | SRC_URI[archive.sha256sum] = "e15e31329e0171229d552d25563f176c5b6179795bf91fae2b141f69a9b7c480" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 24 | |
| 25 | PACKAGECONFIG ??= " \ |
| 26 | ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \ |
| 27 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'gtk', '', d)} \ |
| 28 | ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'gtk', '', d)} \ |
Andrew Geissler | 6aa7eec | 2023-03-03 12:41:14 -0600 | [diff] [blame] | 29 | ${@bb.utils.contains('GI_DATA_ENABLED', 'True', 'vapi', '', d)} \ |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 30 | " |
| 31 | PACKAGECONFIG[gtk] = "-Dgtk4=true,-Dgtk4=false,gtk4" |
| 32 | PACKAGECONFIG[ssh_agent] = "-Dssh_agent=true,-Dssh_agent=false,libsecret,openssh" |
| 33 | #'Use systemd socket activation for server programs' |
| 34 | PACKAGECONFIG[systemd] = "-Dsystemd=enabled,-Dsystemd=disabled,systemd" |
Andrew Geissler | 6aa7eec | 2023-03-03 12:41:14 -0600 | [diff] [blame] | 35 | PACKAGECONFIG[vapi] = "-Dvapi=true,-Dvapi=false," |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 36 | |
| 37 | FILES:${PN} += " \ |
| 38 | ${datadir}/dbus-1 \ |
| 39 | ${datadir}/gcr-4 \ |
| 40 | ${systemd_user_unitdir}/gcr-ssh-agent.socket \ |
| 41 | ${systemd_user_unitdir}/gcr-ssh-agent.service \ |
| 42 | " |
| 43 | |
| 44 | # http://errors.yoctoproject.org/Errors/Details/20229/ |
| 45 | ARM_INSTRUCTION_SET:armv4 = "arm" |
| 46 | ARM_INSTRUCTION_SET:armv5 = "arm" |
| 47 | ARM_INSTRUCTION_SET:armv6 = "arm" |
| 48 | |
| 49 | EXTRA_OEMESON += "--cross-file=${WORKDIR}/meson-${PN}.cross" |
| 50 | |
| 51 | do_write_config:append() { |
| 52 | cat >${WORKDIR}/meson-${PN}.cross <<EOF |
| 53 | [binaries] |
| 54 | gpg2 = '${bindir}/gpg2' |
| 55 | ssh-add = '${bindir}/ssh-add' |
| 56 | ssh-agent = '${bindir}/ssh-agent' |
| 57 | EOF |
| 58 | } |