Andrew Geissler | 220dafd | 2023-10-04 10:18:08 -0500 | [diff] [blame] | 1 | SUMMARY = "IDN Perl module" |
| 2 | DESCRIPTION = "This module provides an easy-to-use interface for encoding \ |
| 3 | and decoding Internationalized Domain Names (IDNs)." |
| 4 | |
| 5 | SECTION = "libs" |
| 6 | |
| 7 | LICENSE = "Artistic-1.0 | GPL-1.0-or-later" |
| 8 | LIC_FILES_CHKSUM = "file://LICENSE;md5=8ea5704cf65ca4ec6e9e167fb94f14dd" |
| 9 | |
| 10 | SRC_URI = "${CPAN_MIRROR}/authors/id/C/CF/CFAERBER/Net-IDN-Encode-${PV}.tar.gz" |
| 11 | SRC_URI[sha256sum] = "55453633e3ff24ce325b34bc2c8157b9859962a31ab5cf28bf7ccc1c9b3a3eaa" |
| 12 | |
| 13 | S = "${WORKDIR}/Net-IDN-Encode-${PV}" |
| 14 | |
| 15 | inherit cpan ptest-perl |
| 16 | |
| 17 | do_configure:prepend() { |
| 18 | perl -pi -e 's/auto_install_now.*//g' Makefile.PL |
| 19 | } |
| 20 | |
| 21 | BBCLASSEXTEND = "native" |
| 22 | |
| 23 | RDEPENDS:${PN} += "perl-module-unicode-normalize" |