Lotus Xu | 58c4886 | 2020-10-27 15:00:31 +0800 | [diff] [blame] | 1 | SUMMARY = "Enforce static MAC addresses" |
| 2 | DESCRIPTION = "Set a priority on MAC addresses to run with: \ |
| 3 | factory-specified > u-boot-specified > random" |
| 4 | |
Lei YU | 05e5f0b | 2021-08-12 11:08:52 +0800 | [diff] [blame] | 5 | FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:" |
Lotus Xu | 58c4886 | 2020-10-27 15:00:31 +0800 | [diff] [blame] | 6 | |
| 7 | PR = "r1" |
| 8 | LICENSE = "Apache-2.0" |
| 9 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" |
| 10 | |
| 11 | inherit allarch |
| 12 | SRC_URI = "\ |
| 13 | file://mac-check \ |
| 14 | file://${PN}.service \ |
| 15 | " |
| 16 | |
| 17 | inherit obmc-phosphor-systemd |
| 18 | |
Lei YU | 05e5f0b | 2021-08-12 11:08:52 +0800 | [diff] [blame] | 19 | SYSTEMD_SERVICE:${PN} += "${PN}.service" |
Lotus Xu | 58c4886 | 2020-10-27 15:00:31 +0800 | [diff] [blame] | 20 | |
| 21 | do_install() { |
| 22 | install -d ${D}${bindir} |
| 23 | install -m 0755 ${WORKDIR}/mac-check ${D}${bindir} |
| 24 | } |
Patrick Williams | 2ceeb11 | 2023-04-14 08:45:22 -0500 | [diff] [blame] | 25 | |
| 26 | RDEPENDS:${PN}:append = " bash" |