Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | SUMMARY = "Skip tests when modules not available" |
| 2 | DESCRIPTION = "Skip test scripts if modules are not available. \ |
| 3 | The requested modules will be loaded, and optionally have their versions \ |
| 4 | checked. If the module is missing, the test script will be skipped. Modules \ |
| 5 | that are found but fail to compile will exit with an error rather than skip." |
| 6 | |
| 7 | HOMEPAGE = "https://metacpan.org/release/Test-Needs" |
| 8 | SECTION = "libs" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 9 | LICENSE = "Artistic-1.0 | GPL-1.0-or-later" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 10 | |
| 11 | CPAN_NAME = "Test-Needs" |
| 12 | CPAN_AUTHOR = "HAARG" |
| 13 | |
Brad Bishop | 393846f | 2019-05-20 12:24:11 -0400 | [diff] [blame] | 14 | LIC_FILES_CHKSUM = "file://README;md5=3f3ccd21a0a48aa313db212cc3b1bc09;beginline=88;endline=89" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 15 | |
| 16 | DEPENDS += "perl" |
| 17 | |
Brad Bishop | 393846f | 2019-05-20 12:24:11 -0400 | [diff] [blame] | 18 | SRC_URI = "https://cpan.metacpan.org/authors/id/H/HA/${CPAN_AUTHOR}/${CPAN_NAME}-${PV}.tar.gz" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 19 | |
Patrick Williams | 864cc43 | 2023-02-09 14:54:44 -0600 | [diff] [blame] | 20 | SRC_URI[sha256sum] = "923ffdc78fcba96609753e4bae26b0ba0186893de4a63cd5236e012c7c90e208" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 21 | |
| 22 | S = "${WORKDIR}/${CPAN_NAME}-${PV}" |
| 23 | |
| 24 | inherit cpan ptest-perl |
| 25 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 26 | RDEPENDS:${PN}-ptest += "perl-module-test-more perl-module-ipc-open3 perl-module-lib perl-module-version" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 27 | |
| 28 | BBCLASSEXTEND = "native" |