Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "Enca is an Extremely Naive Charset Analyser" |
| 2 | SECTION = "libs" |
| 3 | HOMEPAGE = "http://trific.ath.cx/software/enca/" |
| 4 | |
| 5 | DEPENDS += "gettext-native" |
| 6 | |
| 7 | LICENSE = "GPLv2" |
| 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=24b9569831c46d4818450b55282476b4" |
| 9 | |
| 10 | SRC_URI = "http://www.sourcefiles.org/Networking/Tools/Miscellanenous/enca-${PV}.tar.bz2 \ |
| 11 | file://configure-hack.patch \ |
| 12 | file://dont-run-tests.patch \ |
| 13 | file://configure-remove-dumbness.patch \ |
| 14 | file://makefile-remove-tools.patch \ |
| 15 | file://libenca-003-iconv.patch " |
| 16 | |
| 17 | SRC_URI[md5sum] = "b3581e28d68d452286fb0bfe58bed3b3" |
| 18 | SRC_URI[sha256sum] = "02acfef2b24a9c842612da49338138311f909f1cd33933520c07b8b26c410f4d" |
| 19 | |
| 20 | inherit autotools |
| 21 | |
| 22 | do_configure_prepend() { |
| 23 | # remove failing test which checks for something that isn't even used |
| 24 | sed -i -e '/ye_FUNC_SCANF_MODIF_SIZE_T/d' ${S}/configure.ac |
| 25 | } |
| 26 | |
| 27 | do_configure_append() { |
| 28 | sed -i s:-I/usr/include::g ${B}/Makefile |
| 29 | sed -i s:-I/usr/include::g ${B}/*/Makefile |
| 30 | } |
| 31 | |
| 32 | do_compile() { |
| 33 | cd ${S}/tools && ${BUILD_CC} -o make_hash make_hash.c |
| 34 | cd ${B} |
| 35 | oe_runmake |
| 36 | } |
| 37 | |