Andrew Geissler | 615f2f1 | 2022-07-15 14:00:58 -0500 | [diff] [blame] | 1 | SUMMARY = "Memory Efficient Serialization Library" |
| 2 | HOMEPAGE = "https://github.com/google/flatbuffers" |
| 3 | SECTION = "console/tools" |
| 4 | LICENSE = "Apache-2.0" |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 5 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3b83ef96387f14655fc854ddc3c6bd57" |
| 6 | |
| 7 | require flatbuffers.inc |
Andrew Geissler | 615f2f1 | 2022-07-15 14:00:58 -0500 | [diff] [blame] | 8 | |
| 9 | PACKAGE_BEFORE_PN = "${PN}-compiler" |
| 10 | |
| 11 | DEPENDS = "flatbuffers-native" |
| 12 | |
| 13 | RDEPENDS:${PN}-compiler = "${PN}" |
| 14 | RDEPENDS:${PN}-dev += "${PN}-compiler" |
| 15 | |
Andrew Geissler | 615f2f1 | 2022-07-15 14:00:58 -0500 | [diff] [blame] | 16 | S = "${WORKDIR}/git" |
| 17 | |
| 18 | CVE_CHECK_IGNORE += "CVE-2020-35864" |
| 19 | |
| 20 | EXTRA_OECMAKE += " \ |
| 21 | -DFLATBUFFERS_BUILD_TESTS=OFF \ |
| 22 | -DFLATBUFFERS_BUILD_SHAREDLIB=ON \ |
| 23 | " |
| 24 | EXTRA_OECMAKE:append:class-target = " -DFLATBUFFERS_FLATC_EXECUTABLE=${STAGING_BINDIR_NATIVE}/flatc" |
| 25 | |
| 26 | inherit cmake python3native |
| 27 | |
| 28 | FILES:${PN}-compiler = "${bindir}" |
| 29 | |
| 30 | BBCLASSEXTEND = "native nativesdk" |