blob: 3af41bed292c5720bf0e34f879b5d93a877099dc [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001DESCRIPTION = "Python SQL toolkit and Object Relational Mapper that gives \
2application developers the full power and flexibility of SQL"
3HOMEPAGE = "http://www.sqlalchemy.org/"
4LICENSE = "MIT"
Andrew Geisslerc5535c92023-01-27 16:10:19 -06005LIC_FILES_CHKSUM = "file://LICENSE;md5=b707d50badb798e1d897f2c8f649382d"
Andrew Geissler517393d2023-01-13 08:55:19 -06006
Patrick Williamse760df82023-05-26 11:10:49 -05007SRC_URI[sha256sum] = "2e940a8659ef870ae10e0d9e2a6d5aaddf0ff6e91f7d0d7732afc9e8c4be9bbc"
Andrew Geissler517393d2023-01-13 08:55:19 -06008
9PYPI_PACKAGE = "SQLAlchemy"
10inherit pypi setuptools3
11
12RDEPENDS:${PN} += " \
13 ${PYTHON_PN}-json \
14 ${PYTHON_PN}-pickle \
15 ${PYTHON_PN}-logging \
16 ${PYTHON_PN}-netclient \
17 ${PYTHON_PN}-numbers \
18 ${PYTHON_PN}-threading \
19 ${PYTHON_PN}-compression \
20 ${PYTHON_PN}-profile \
21"
22
23BBCLASSEXTEND = "native nativesdk"