blob: 5cbe4551c0631d727fc87ffb5c38d2106467d8bf [file] [log] [blame]
Andrew Geisslerd688a012020-09-18 13:36:00 -05001SUMMARY = "Emacs is the extensible, customizable, self-documenting real-time display editor"
2HOMEPAGE = "https://www.gnu.org/software/emacs/"
3
Andrew Geissler9aee5002022-03-30 16:27:02 +00004LICENSE = "GPL-3.0-only"
Andrew Geisslerd688a012020-09-18 13:36:00 -05005LIC_FILES_CHKSUM = "file://COPYING;md5=1ebbd3e34237af26da5dc08a4e440464"
6
Andrew Geisslerf103a7f2021-05-07 16:09:40 -05007SRC_URI = "https://ftp.gnu.org/pub/gnu/emacs/emacs-${PV}.tar.xz \
Andrew Geisslerf103a7f2021-05-07 16:09:40 -05008 "
Andrew Geissler5082cc72023-09-11 08:41:39 -04009SRC_URI:append:class-target = " \
10 file://use-emacs-native-tools-for-cross-compiling.patch \
11 file://avoid-running-host-binaries-for-sanity.patch \
12"
Andrew Geisslerd688a012020-09-18 13:36:00 -050013
Andrew Geissler5082cc72023-09-11 08:41:39 -040014SRC_URI[sha256sum] = "d2f881a5cc231e2f5a03e86f4584b0438f83edd7598a09d24a21bd8d003e2e01"
Andrew Geisslerd688a012020-09-18 13:36:00 -050015
Patrick Williams2a254922023-08-11 09:48:11 -050016CVE_STATUS[CVE-2007-6109] = "fixed-version: The CPE in the NVD database doesn't reflect correctly the vulnerable versions."
Patrick Williamsdb4c27e2022-08-05 08:10:29 -050017
Andrew Geisslerd688a012020-09-18 13:36:00 -050018PACKAGECONFIG[gnutls] = "--with-gnutls=yes,--with-gnutls=no,gnutls"
19PACKAGECONFIG[kerberos] = "--with-kerberos=yes,--with-kerberos=no,krb5"
20PACKAGECONFIG[libgmp] = "--with-libgmp=yes,--with-libgmp=no,gmp"
Patrick Williamsb58112e2024-03-07 11:16:36 -060021PACKAGECONFIG[selinux] = "--with-selinux=yes,--with-selinux=no,libselinux"
Andrew Geisslerd688a012020-09-18 13:36:00 -050022
23PACKAGECONFIG ??= "gnutls kerberos libgmp"
24
25# We could use --without-all but its better to
26# split it into several packages (size of minimal doesnt change)
Andrew Geissler87f5cff2022-09-30 13:13:31 -050027EXTRA_OECONF = " --with-x=no --with-dumping=none --disable-build-details"
28
29# Disable seccomp, as its a default dependency for gnutls but it doesnt work when cross-compiling emacs
30EXTRA_OECONF:append = " ${@bb.utils.contains('PACKAGECONFIG', 'gnutls', 'ac_cv_have_decl_SECCOMP_FILTER_FLAG_TSYNC=no ac_cv_have_decl_SECCOMP_SET_MODE_FILTER=no', '', d)}"
31
Andrew Geisslerd688a012020-09-18 13:36:00 -050032
33DEPENDS = "ncurses"
Patrick Williams213cb262021-08-07 19:21:33 -050034DEPENDS:append:class-target = " emacs-native"
Andrew Geisslerd688a012020-09-18 13:36:00 -050035
Andrew Geissler5199d832021-09-24 16:47:35 -050036inherit autotools mime-xdg pkgconfig
Andrew Geisslerd688a012020-09-18 13:36:00 -050037
Andrew Geissler5082cc72023-09-11 08:41:39 -040038
39# Create the required native tools for the target build
40do_compile:class-native (){
41 cd ${B}/lib-src
42 oe_runmake make-docfile
43 oe_runmake make-fingerprint
44 cd ${B}/src
45 oe_runmake bootstrap-emacs
46}
47
48do_install:class-native(){
49 install -d ${D}${bindir}
50 install -m 755 ${B}/lib-src/make-docfile ${D}/${bindir}/
51 install -m 755 ${B}/lib-src/make-fingerprint ${D}/${bindir}/
52 install -m 755 ${B}/src/bootstrap-emacs ${D}/${bindir}/
53}
54
55do_compile:prepend:class-target () {
56 # export EMACS env variables for the native tools to use to allow calling bootstrap-emacs
57 export EMACSLOADPATH=${S}/lisp
58 export EMACSDATA=${S}/etc
59}
60
61
62do_install:prepend:class-target(){
63 # export EMACS env variables for the native tools to use to allow calling bootstrap-emacs
64 export EMACSLOADPATH=${S}/lisp
65 export EMACSDATA=${S}/etc
66}
67
Andrew Geissler87f5cff2022-09-30 13:13:31 -050068# Remove build host references to avoid target pollution
69do_compile:prepend () {
70 sed -i -e 's|${TMPDIR}||g' ${B}/src/config.h
71 sed -i -e 's|${B}||g' ${B}/src/epaths.h
72}
73
Patrick Williams213cb262021-08-07 19:21:33 -050074do_install:append(){
Andrew Geisslerd688a012020-09-18 13:36:00 -050075 # Delete systemd stuff, extend using DISTRO_FEATURES?
76 rm -rf ${D}/${libdir}
77 # Extra stuff which isnt needed
78 rm -rf ${D}/${datadir}/metainfo
79 rm -rf ${D}/${datadir}/info
80 # Emacs copies files to ${D} while building, which were unpacked
81 # by a different user, we need to restore those
82 chown -R root:root ${D}${datadir}
83}
84
Andrew Geisslerd688a012020-09-18 13:36:00 -050085# Use a similar strategy to how we build python:
86# Create three packages
87# minimal - A working lisp based text editor
88# base - What would probably work for most
89# full - A fully working emacs
90# The lists of files are long but are worth it
91# Installing "emacs" installs the base package
92PACKAGE_BEFORE_PN = "${PN}-minimal ${PN}-base ${PN}-full"
Patrick Williams213cb262021-08-07 19:21:33 -050093RPROVIDES:${PN}-base = "${PN}"
94RDEPENDS:${PN}-base:class-target = "${PN}-minimal"
95RDEPENDS:${PN}-full:class-target = "${PN}"
Andrew Geisslerd688a012020-09-18 13:36:00 -050096
97
98# A minimal version of emacs that works
Andrew Geissler87f5cff2022-09-30 13:13:31 -050099# These are kept sorted in alphabetical order
Patrick Williams213cb262021-08-07 19:21:33 -0500100FILES:${PN}-minimal = " \
Andrew Geissler87f5cff2022-09-30 13:13:31 -0500101 ${bindir}/emacs* \
102 ${datadir}/${BPN}/${PV}/etc/charsets/ \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500103 ${datadir}/${BPN}/${PV}/lisp/abbrev.elc \
Andrew Geissler87f5cff2022-09-30 13:13:31 -0500104 ${datadir}/${BPN}/${PV}/lisp/bindings.elc \
105 ${datadir}/${BPN}/${PV}/lisp/buff-menu.elc \
106 ${datadir}/${BPN}/${PV}/lisp/button.elc \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500107 ${datadir}/${BPN}/${PV}/lisp/case-table.elc \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500108 ${datadir}/${BPN}/${PV}/lisp/composite.elc \
Andrew Geissler87f5cff2022-09-30 13:13:31 -0500109 ${datadir}/${BPN}/${PV}/lisp/cus-face.elc \
110 ${datadir}/${BPN}/${PV}/lisp/cus-start.elc \
111 ${datadir}/${BPN}/${PV}/lisp/custom.elc \
112 ${datadir}/${BPN}/${PV}/lisp/disp-table.elc \
113 ${datadir}/${BPN}/${PV}/lisp/electric.elc \
114 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/backquote.elc \
115 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/byte-opt.elc \
116 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/byte-run.elc \
117 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/bytecomp.elc \
118 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/cconv.elc \
119 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/cl-generic.elc \
Andrew Geissler5082cc72023-09-11 08:41:39 -0400120 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/cl-lib.elc \
121 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/cl-macs.elc \
Andrew Geissler87f5cff2022-09-30 13:13:31 -0500122 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/cl-preloaded.elc \
Andrew Geissler5082cc72023-09-11 08:41:39 -0400123 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/cl-seq.elc \
124 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/debug-early.elc \
125 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/easy-mmode.elc \
Andrew Geissler87f5cff2022-09-30 13:13:31 -0500126 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/easymenu.elc \
127 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/eldoc.elc \
128 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/float-sup.elc \
129 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/gv.elc \
Andrew Geissler5082cc72023-09-11 08:41:39 -0400130 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/inline.elc \
Andrew Geissler87f5cff2022-09-30 13:13:31 -0500131 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/lisp-mode.elc \
132 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/lisp.elc \
133 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/macroexp.elc \
134 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/map-ynp.elc \
135 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/map.elc \
136 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/nadvice.elc \
Andrew Geissler5082cc72023-09-11 08:41:39 -0400137 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/oclosure.elc \
138 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/pcase.elc \
Andrew Geissler87f5cff2022-09-30 13:13:31 -0500139 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/regexp-opt.elc \
Andrew Geissler5082cc72023-09-11 08:41:39 -0400140 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/rmc.elc \
141 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/rx.elc \
Andrew Geissler87f5cff2022-09-30 13:13:31 -0500142 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/seq.elc \
143 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/shorthands.elc \
144 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/subr-x.elc \
145 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/syntax.elc \
146 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/tabulated-list.elc \
147 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/timer.elc \
148 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/vc/warnings.elc \
149 ${datadir}/${BPN}/${PV}/lisp/env.elc \
150 ${datadir}/${BPN}/${PV}/lisp/epa-hook.elc \
151 ${datadir}/${BPN}/${PV}/lisp/facemenu.elc \
152 ${datadir}/${BPN}/${PV}/lisp/faces.elc \
153 ${datadir}/${BPN}/${PV}/lisp/files.elc \
154 ${datadir}/${BPN}/${PV}/lisp/font-core.elc \
155 ${datadir}/${BPN}/${PV}/lisp/font-lock.elc \
156 ${datadir}/${BPN}/${PV}/lisp/format.elc \
157 ${datadir}/${BPN}/${PV}/lisp/frame.elc \
158 ${datadir}/${BPN}/${PV}/lisp/help.elc \
159 ${datadir}/${BPN}/${PV}/lisp/image.elc \
160 ${datadir}/${BPN}/${PV}/lisp/indent.elc \
161 ${datadir}/${BPN}/${PV}/lisp/international/characters.elc \
162 ${datadir}/${BPN}/${PV}/lisp/international/charprop.el \
163 ${datadir}/${BPN}/${PV}/lisp/international/charscript.elc \
164 ${datadir}/${BPN}/${PV}/lisp/international/cp51932.elc \
165 ${datadir}/${BPN}/${PV}/lisp/international/emoji-zwj.elc \
166 ${datadir}/${BPN}/${PV}/lisp/international/eucjp-ms.elc \
167 ${datadir}/${BPN}/${PV}/lisp/international/iso-transl.elc \
168 ${datadir}/${BPN}/${PV}/lisp/international/mule-cmds.elc \
169 ${datadir}/${BPN}/${PV}/lisp/international/mule-conf.elc \
170 ${datadir}/${BPN}/${PV}/lisp/international/mule.elc \
171 ${datadir}/${BPN}/${PV}/lisp/international/uni*.el \
172 ${datadir}/${BPN}/${PV}/lisp/isearch.elc \
173 ${datadir}/${BPN}/${PV}/lisp/jit-lock.elc \
174 ${datadir}/${BPN}/${PV}/lisp/jka-cmpr-hook.elc \
Andrew Geissler5082cc72023-09-11 08:41:39 -0400175 ${datadir}/${BPN}/${PV}/lisp/jka-compr.elc \
176 ${datadir}/${BPN}/${PV}/lisp/keymap.elc \
Andrew Geissler87f5cff2022-09-30 13:13:31 -0500177 ${datadir}/${BPN}/${PV}/lisp/language/burmese.elc \
178 ${datadir}/${BPN}/${PV}/lisp/language/cham.elc \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500179 ${datadir}/${BPN}/${PV}/lisp/language/chinese.elc \
180 ${datadir}/${BPN}/${PV}/lisp/language/cyrillic.elc \
Andrew Geissler87f5cff2022-09-30 13:13:31 -0500181 ${datadir}/${BPN}/${PV}/lisp/language/czech.elc \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500182 ${datadir}/${BPN}/${PV}/lisp/language/english.elc \
183 ${datadir}/${BPN}/${PV}/lisp/language/ethiopic.elc \
184 ${datadir}/${BPN}/${PV}/lisp/language/european.elc \
Andrew Geissler87f5cff2022-09-30 13:13:31 -0500185 ${datadir}/${BPN}/${PV}/lisp/language/georgian.elc \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500186 ${datadir}/${BPN}/${PV}/lisp/language/greek.elc \
187 ${datadir}/${BPN}/${PV}/lisp/language/hebrew.elc \
Andrew Geissler87f5cff2022-09-30 13:13:31 -0500188 ${datadir}/${BPN}/${PV}/lisp/language/indian.elc \
Andrew Geissler5082cc72023-09-11 08:41:39 -0400189 ${datadir}/${BPN}/${PV}/lisp/language/indonesian.elc \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500190 ${datadir}/${BPN}/${PV}/lisp/language/japanese.elc \
Andrew Geissler87f5cff2022-09-30 13:13:31 -0500191 ${datadir}/${BPN}/${PV}/lisp/language/khmer.elc \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500192 ${datadir}/${BPN}/${PV}/lisp/language/korean.elc \
193 ${datadir}/${BPN}/${PV}/lisp/language/lao.elc \
Andrew Geissler87f5cff2022-09-30 13:13:31 -0500194 ${datadir}/${BPN}/${PV}/lisp/language/misc-lang.elc \
Andrew Geissler5082cc72023-09-11 08:41:39 -0400195 ${datadir}/${BPN}/${PV}/lisp/language/philippine.elc \
Andrew Geissler87f5cff2022-09-30 13:13:31 -0500196 ${datadir}/${BPN}/${PV}/lisp/language/romanian.elc \
197 ${datadir}/${BPN}/${PV}/lisp/language/sinhala.elc \
198 ${datadir}/${BPN}/${PV}/lisp/language/slovak.elc \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500199 ${datadir}/${BPN}/${PV}/lisp/language/tai-viet.elc \
200 ${datadir}/${BPN}/${PV}/lisp/language/thai.elc \
201 ${datadir}/${BPN}/${PV}/lisp/language/tibetan.elc \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500202 ${datadir}/${BPN}/${PV}/lisp/language/utf-8-lang.elc \
Andrew Geissler87f5cff2022-09-30 13:13:31 -0500203 ${datadir}/${BPN}/${PV}/lisp/language/vietnamese.elc \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500204 ${datadir}/${BPN}/${PV}/lisp/ldefs-boot.el \
Andrew Geissler87f5cff2022-09-30 13:13:31 -0500205 ${datadir}/${BPN}/${PV}/lisp/loaddefs.el \
206 ${datadir}/${BPN}/${PV}/lisp/loadup.el \
207 ${datadir}/${BPN}/${PV}/lisp/menu-bar.elc \
208 ${datadir}/${BPN}/${PV}/lisp/minibuffer.elc \
209 ${datadir}/${BPN}/${PV}/lisp/mouse.elc \
210 ${datadir}/${BPN}/${PV}/lisp/newcomment.elc \
211 ${datadir}/${BPN}/${PV}/lisp/obarray.elc \
212 ${datadir}/${BPN}/${PV}/lisp/paren.elc \
213 ${datadir}/${BPN}/${PV}/lisp/progmodes/elisp-mode.elc \
214 ${datadir}/${BPN}/${PV}/lisp/progmodes/prog-mode.elc \
215 ${datadir}/${BPN}/${PV}/lisp/register.elc \
216 ${datadir}/${BPN}/${PV}/lisp/replace.elc \
217 ${datadir}/${BPN}/${PV}/lisp/rfn-eshadow.elc \
218 ${datadir}/${BPN}/${PV}/lisp/select.elc \
219 ${datadir}/${BPN}/${PV}/lisp/simple.elc \
Andrew Geissler87f5cff2022-09-30 13:13:31 -0500220 ${datadir}/${BPN}/${PV}/lisp/startup.elc \
221 ${datadir}/${BPN}/${PV}/lisp/subr.elc \
222 ${datadir}/${BPN}/${PV}/lisp/tab-bar.elc \
223 ${datadir}/${BPN}/${PV}/lisp/term/tty-colors.elc \
224 ${datadir}/${BPN}/${PV}/lisp/term/xterm.elc \
225 ${datadir}/${BPN}/${PV}/lisp/textmodes/fill.elc \
226 ${datadir}/${BPN}/${PV}/lisp/textmodes/page.elc \
227 ${datadir}/${BPN}/${PV}/lisp/textmodes/paragraphs.elc \
228 ${datadir}/${BPN}/${PV}/lisp/textmodes/text-mode.elc \
Andrew Geissler5082cc72023-09-11 08:41:39 -0400229 ${datadir}/${BPN}/${PV}/lisp/thingatpt.elc \
Andrew Geissler87f5cff2022-09-30 13:13:31 -0500230 ${datadir}/${BPN}/${PV}/lisp/tooltip.elc \
231 ${datadir}/${BPN}/${PV}/lisp/uniquify.elc \
232 ${datadir}/${BPN}/${PV}/lisp/vc/ediff-hook.elc \
233 ${datadir}/${BPN}/${PV}/lisp/vc/vc-hooks.elc \
234 ${datadir}/${BPN}/${PV}/lisp/version.elc \
235 ${datadir}/${BPN}/${PV}/lisp/widget.elc \
236 ${datadir}/${BPN}/${PV}/lisp/window.elc \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500237 ${prefix}/libexec \
238"
239
Andrew Geisslerd688a012020-09-18 13:36:00 -0500240# What works for "most" is relative, but this can be easily extended if needed
Patrick Williams213cb262021-08-07 19:21:33 -0500241FILES:${PN}-base = " \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500242 ${datadir}/${BPN}/${PV}/etc/e \
243 ${datadir}/${BPN}/${PV}/etc/forms \
Andrew Geissler87f5cff2022-09-30 13:13:31 -0500244 ${datadir}/${BPN}/${PV}/etc/srecode \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500245 ${datadir}/${BPN}/${PV}/etc/themes/adwaita-theme.el \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500246 ${datadir}/${BPN}/${PV}/etc/themes/deeper-blue-theme.el \
247 ${datadir}/${BPN}/${PV}/etc/themes/light-blue-theme.el \
248 ${datadir}/${BPN}/${PV}/etc/themes/misterioso-theme.el \
249 ${datadir}/${BPN}/${PV}/etc/themes/tango-theme.el \
Andrew Geissler87f5cff2022-09-30 13:13:31 -0500250 ${datadir}/${BPN}/${PV}/etc/themes/wheatgrass-theme.el \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500251 ${datadir}/${BPN}/${PV}/etc/themes/wombat-theme.el \
Andrew Geissler87f5cff2022-09-30 13:13:31 -0500252 ${datadir}/${BPN}/${PV}/lisp/ansi-color.elc \
253 ${datadir}/${BPN}/${PV}/lisp/auth-source.elc \
254 ${datadir}/${BPN}/${PV}/lisp/calendar/iso8601.elc \
255 ${datadir}/${BPN}/${PV}/lisp/calendar/parse-time.elc \
256 ${datadir}/${BPN}/${PV}/lisp/calendar/time-date.elc \
257 ${datadir}/${BPN}/${PV}/lisp/cedet \
258 ${datadir}/${BPN}/${PV}/lisp/comint.elc \
259 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/cl-lib.elc \
260 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/cl-macs.elc \
261 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/cl-seq.elc \
262 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/eieio-core.elc \
263 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/eieio.elc \
264 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/inline.elc \
265 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/pcase.elc \
266 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/ring.elc \
267 ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/smie.elc \
268 ${datadir}/${BPN}/${PV}/lisp/files-x.elc \
269 ${datadir}/${BPN}/${PV}/lisp/format-spec.elc \
270 ${datadir}/${BPN}/${PV}/lisp/json.elc \
271 ${datadir}/${BPN}/${PV}/lisp/ls-lisp.elc \
272 ${datadir}/${BPN}/${PV}/lisp/net/tramp-compat.elc \
273 ${datadir}/${BPN}/${PV}/lisp/net/tramp-integration.elc \
274 ${datadir}/${BPN}/${PV}/lisp/net/tramp-loaddefs.el \
275 ${datadir}/${BPN}/${PV}/lisp/net/tramp-sh.elc \
276 ${datadir}/${BPN}/${PV}/lisp/net/tramp.elc \
277 ${datadir}/${BPN}/${PV}/lisp/net/trampver.elc \
278 ${datadir}/${BPN}/${PV}/lisp/password-cache.elc \
279 ${datadir}/${BPN}/${PV}/lisp/pcomplete.elc \
280 ${datadir}/${BPN}/${PV}/lisp/progmodes/*asm* \
281 ${datadir}/${BPN}/${PV}/lisp/progmodes/*perl* \
282 ${datadir}/${BPN}/${PV}/lisp/progmodes/cc-align.elc \
283 ${datadir}/${BPN}/${PV}/lisp/progmodes/cc-cmds.elc \
284 ${datadir}/${BPN}/${PV}/lisp/progmodes/cc-defs.elc \
285 ${datadir}/${BPN}/${PV}/lisp/progmodes/cc-engine.elc \
286 ${datadir}/${BPN}/${PV}/lisp/progmodes/cc-fonts.elc \
287 ${datadir}/${BPN}/${PV}/lisp/progmodes/cc-guess.elc \
288 ${datadir}/${BPN}/${PV}/lisp/progmodes/cc-menus.elc \
289 ${datadir}/${BPN}/${PV}/lisp/progmodes/cc-mode.elc \
290 ${datadir}/${BPN}/${PV}/lisp/progmodes/cc-styles.elc \
291 ${datadir}/${BPN}/${PV}/lisp/progmodes/cc-vars.elc \
292 ${datadir}/${BPN}/${PV}/lisp/progmodes/cpp* \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500293 ${datadir}/${BPN}/${PV}/lisp/progmodes/executable* \
Andrew Geissler87f5cff2022-09-30 13:13:31 -0500294 ${datadir}/${BPN}/${PV}/lisp/progmodes/make* \
295 ${datadir}/${BPN}/${PV}/lisp/progmodes/prog* \
296 ${datadir}/${BPN}/${PV}/lisp/progmodes/python* \
297 ${datadir}/${BPN}/${PV}/lisp/progmodes/sh-script* \
298 ${datadir}/${BPN}/${PV}/lisp/shell.elc \
299 ${datadir}/${BPN}/${PV}/lisp/subdirs.el \
300 ${datadir}/${BPN}/${PV}/site-lisp/ \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500301"
302
303# Restore FILES for the full package to catch everything left
Patrick Williams213cb262021-08-07 19:21:33 -0500304FILES:${PN}-full = "${FILES:${PN}}"
305FILES:${PN}-full:append = " ${datadir}/icons"
Andrew Geisslerd688a012020-09-18 13:36:00 -0500306
307
308# The following does NOT build a native emacs.
309# It only builds some parts of it that are
310# required to by the build for target emacs.
311BBCLASSEXTEND = "native"