Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 1 | SUMMARY = "Emacs is the extensible, customizable, self-documenting real-time display editor" |
| 2 | HOMEPAGE = "https://www.gnu.org/software/emacs/" |
| 3 | |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 4 | LICENSE = "GPL-3.0-only" |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=1ebbd3e34237af26da5dc08a4e440464" |
| 6 | |
Andrew Geissler | f103a7f | 2021-05-07 16:09:40 -0500 | [diff] [blame] | 7 | SRC_URI = "https://ftp.gnu.org/pub/gnu/emacs/emacs-${PV}.tar.xz \ |
Andrew Geissler | f103a7f | 2021-05-07 16:09:40 -0500 | [diff] [blame] | 8 | " |
Andrew Geissler | 5082cc7 | 2023-09-11 08:41:39 -0400 | [diff] [blame] | 9 | SRC_URI:append:class-target = " \ |
| 10 | file://use-emacs-native-tools-for-cross-compiling.patch \ |
| 11 | file://avoid-running-host-binaries-for-sanity.patch \ |
| 12 | " |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 13 | |
Andrew Geissler | 5082cc7 | 2023-09-11 08:41:39 -0400 | [diff] [blame] | 14 | SRC_URI[sha256sum] = "d2f881a5cc231e2f5a03e86f4584b0438f83edd7598a09d24a21bd8d003e2e01" |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 15 | |
Patrick Williams | 2a25492 | 2023-08-11 09:48:11 -0500 | [diff] [blame] | 16 | CVE_STATUS[CVE-2007-6109] = "fixed-version: The CPE in the NVD database doesn't reflect correctly the vulnerable versions." |
Patrick Williams | db4c27e | 2022-08-05 08:10:29 -0500 | [diff] [blame] | 17 | |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 18 | PACKAGECONFIG[gnutls] = "--with-gnutls=yes,--with-gnutls=no,gnutls" |
| 19 | PACKAGECONFIG[kerberos] = "--with-kerberos=yes,--with-kerberos=no,krb5" |
| 20 | PACKAGECONFIG[libgmp] = "--with-libgmp=yes,--with-libgmp=no,gmp" |
Patrick Williams | b58112e | 2024-03-07 11:16:36 -0600 | [diff] [blame^] | 21 | PACKAGECONFIG[selinux] = "--with-selinux=yes,--with-selinux=no,libselinux" |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 22 | |
| 23 | PACKAGECONFIG ??= "gnutls kerberos libgmp" |
| 24 | |
| 25 | # We could use --without-all but its better to |
| 26 | # split it into several packages (size of minimal doesnt change) |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 27 | EXTRA_OECONF = " --with-x=no --with-dumping=none --disable-build-details" |
| 28 | |
| 29 | # Disable seccomp, as its a default dependency for gnutls but it doesnt work when cross-compiling emacs |
| 30 | EXTRA_OECONF:append = " ${@bb.utils.contains('PACKAGECONFIG', 'gnutls', 'ac_cv_have_decl_SECCOMP_FILTER_FLAG_TSYNC=no ac_cv_have_decl_SECCOMP_SET_MODE_FILTER=no', '', d)}" |
| 31 | |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 32 | |
| 33 | DEPENDS = "ncurses" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 34 | DEPENDS:append:class-target = " emacs-native" |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 35 | |
Andrew Geissler | 5199d83 | 2021-09-24 16:47:35 -0500 | [diff] [blame] | 36 | inherit autotools mime-xdg pkgconfig |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 37 | |
Andrew Geissler | 5082cc7 | 2023-09-11 08:41:39 -0400 | [diff] [blame] | 38 | |
| 39 | # Create the required native tools for the target build |
| 40 | do_compile:class-native (){ |
| 41 | cd ${B}/lib-src |
| 42 | oe_runmake make-docfile |
| 43 | oe_runmake make-fingerprint |
| 44 | cd ${B}/src |
| 45 | oe_runmake bootstrap-emacs |
| 46 | } |
| 47 | |
| 48 | do_install:class-native(){ |
| 49 | install -d ${D}${bindir} |
| 50 | install -m 755 ${B}/lib-src/make-docfile ${D}/${bindir}/ |
| 51 | install -m 755 ${B}/lib-src/make-fingerprint ${D}/${bindir}/ |
| 52 | install -m 755 ${B}/src/bootstrap-emacs ${D}/${bindir}/ |
| 53 | } |
| 54 | |
| 55 | do_compile:prepend:class-target () { |
| 56 | # export EMACS env variables for the native tools to use to allow calling bootstrap-emacs |
| 57 | export EMACSLOADPATH=${S}/lisp |
| 58 | export EMACSDATA=${S}/etc |
| 59 | } |
| 60 | |
| 61 | |
| 62 | do_install:prepend:class-target(){ |
| 63 | # export EMACS env variables for the native tools to use to allow calling bootstrap-emacs |
| 64 | export EMACSLOADPATH=${S}/lisp |
| 65 | export EMACSDATA=${S}/etc |
| 66 | } |
| 67 | |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 68 | # Remove build host references to avoid target pollution |
| 69 | do_compile:prepend () { |
| 70 | sed -i -e 's|${TMPDIR}||g' ${B}/src/config.h |
| 71 | sed -i -e 's|${B}||g' ${B}/src/epaths.h |
| 72 | } |
| 73 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 74 | do_install:append(){ |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 75 | # Delete systemd stuff, extend using DISTRO_FEATURES? |
| 76 | rm -rf ${D}/${libdir} |
| 77 | # Extra stuff which isnt needed |
| 78 | rm -rf ${D}/${datadir}/metainfo |
| 79 | rm -rf ${D}/${datadir}/info |
| 80 | # Emacs copies files to ${D} while building, which were unpacked |
| 81 | # by a different user, we need to restore those |
| 82 | chown -R root:root ${D}${datadir} |
| 83 | } |
| 84 | |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 85 | # Use a similar strategy to how we build python: |
| 86 | # Create three packages |
| 87 | # minimal - A working lisp based text editor |
| 88 | # base - What would probably work for most |
| 89 | # full - A fully working emacs |
| 90 | # The lists of files are long but are worth it |
| 91 | # Installing "emacs" installs the base package |
| 92 | PACKAGE_BEFORE_PN = "${PN}-minimal ${PN}-base ${PN}-full" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 93 | RPROVIDES:${PN}-base = "${PN}" |
| 94 | RDEPENDS:${PN}-base:class-target = "${PN}-minimal" |
| 95 | RDEPENDS:${PN}-full:class-target = "${PN}" |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 96 | |
| 97 | |
| 98 | # A minimal version of emacs that works |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 99 | # These are kept sorted in alphabetical order |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 100 | FILES:${PN}-minimal = " \ |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 101 | ${bindir}/emacs* \ |
| 102 | ${datadir}/${BPN}/${PV}/etc/charsets/ \ |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 103 | ${datadir}/${BPN}/${PV}/lisp/abbrev.elc \ |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 104 | ${datadir}/${BPN}/${PV}/lisp/bindings.elc \ |
| 105 | ${datadir}/${BPN}/${PV}/lisp/buff-menu.elc \ |
| 106 | ${datadir}/${BPN}/${PV}/lisp/button.elc \ |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 107 | ${datadir}/${BPN}/${PV}/lisp/case-table.elc \ |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 108 | ${datadir}/${BPN}/${PV}/lisp/composite.elc \ |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 109 | ${datadir}/${BPN}/${PV}/lisp/cus-face.elc \ |
| 110 | ${datadir}/${BPN}/${PV}/lisp/cus-start.elc \ |
| 111 | ${datadir}/${BPN}/${PV}/lisp/custom.elc \ |
| 112 | ${datadir}/${BPN}/${PV}/lisp/disp-table.elc \ |
| 113 | ${datadir}/${BPN}/${PV}/lisp/electric.elc \ |
| 114 | ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/backquote.elc \ |
| 115 | ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/byte-opt.elc \ |
| 116 | ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/byte-run.elc \ |
| 117 | ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/bytecomp.elc \ |
| 118 | ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/cconv.elc \ |
| 119 | ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/cl-generic.elc \ |
Andrew Geissler | 5082cc7 | 2023-09-11 08:41:39 -0400 | [diff] [blame] | 120 | ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/cl-lib.elc \ |
| 121 | ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/cl-macs.elc \ |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 122 | ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/cl-preloaded.elc \ |
Andrew Geissler | 5082cc7 | 2023-09-11 08:41:39 -0400 | [diff] [blame] | 123 | ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/cl-seq.elc \ |
| 124 | ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/debug-early.elc \ |
| 125 | ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/easy-mmode.elc \ |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 126 | ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/easymenu.elc \ |
| 127 | ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/eldoc.elc \ |
| 128 | ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/float-sup.elc \ |
| 129 | ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/gv.elc \ |
Andrew Geissler | 5082cc7 | 2023-09-11 08:41:39 -0400 | [diff] [blame] | 130 | ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/inline.elc \ |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 131 | ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/lisp-mode.elc \ |
| 132 | ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/lisp.elc \ |
| 133 | ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/macroexp.elc \ |
| 134 | ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/map-ynp.elc \ |
| 135 | ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/map.elc \ |
| 136 | ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/nadvice.elc \ |
Andrew Geissler | 5082cc7 | 2023-09-11 08:41:39 -0400 | [diff] [blame] | 137 | ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/oclosure.elc \ |
| 138 | ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/pcase.elc \ |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 139 | ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/regexp-opt.elc \ |
Andrew Geissler | 5082cc7 | 2023-09-11 08:41:39 -0400 | [diff] [blame] | 140 | ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/rmc.elc \ |
| 141 | ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/rx.elc \ |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 142 | ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/seq.elc \ |
| 143 | ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/shorthands.elc \ |
| 144 | ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/subr-x.elc \ |
| 145 | ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/syntax.elc \ |
| 146 | ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/tabulated-list.elc \ |
| 147 | ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/timer.elc \ |
| 148 | ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/vc/warnings.elc \ |
| 149 | ${datadir}/${BPN}/${PV}/lisp/env.elc \ |
| 150 | ${datadir}/${BPN}/${PV}/lisp/epa-hook.elc \ |
| 151 | ${datadir}/${BPN}/${PV}/lisp/facemenu.elc \ |
| 152 | ${datadir}/${BPN}/${PV}/lisp/faces.elc \ |
| 153 | ${datadir}/${BPN}/${PV}/lisp/files.elc \ |
| 154 | ${datadir}/${BPN}/${PV}/lisp/font-core.elc \ |
| 155 | ${datadir}/${BPN}/${PV}/lisp/font-lock.elc \ |
| 156 | ${datadir}/${BPN}/${PV}/lisp/format.elc \ |
| 157 | ${datadir}/${BPN}/${PV}/lisp/frame.elc \ |
| 158 | ${datadir}/${BPN}/${PV}/lisp/help.elc \ |
| 159 | ${datadir}/${BPN}/${PV}/lisp/image.elc \ |
| 160 | ${datadir}/${BPN}/${PV}/lisp/indent.elc \ |
| 161 | ${datadir}/${BPN}/${PV}/lisp/international/characters.elc \ |
| 162 | ${datadir}/${BPN}/${PV}/lisp/international/charprop.el \ |
| 163 | ${datadir}/${BPN}/${PV}/lisp/international/charscript.elc \ |
| 164 | ${datadir}/${BPN}/${PV}/lisp/international/cp51932.elc \ |
| 165 | ${datadir}/${BPN}/${PV}/lisp/international/emoji-zwj.elc \ |
| 166 | ${datadir}/${BPN}/${PV}/lisp/international/eucjp-ms.elc \ |
| 167 | ${datadir}/${BPN}/${PV}/lisp/international/iso-transl.elc \ |
| 168 | ${datadir}/${BPN}/${PV}/lisp/international/mule-cmds.elc \ |
| 169 | ${datadir}/${BPN}/${PV}/lisp/international/mule-conf.elc \ |
| 170 | ${datadir}/${BPN}/${PV}/lisp/international/mule.elc \ |
| 171 | ${datadir}/${BPN}/${PV}/lisp/international/uni*.el \ |
| 172 | ${datadir}/${BPN}/${PV}/lisp/isearch.elc \ |
| 173 | ${datadir}/${BPN}/${PV}/lisp/jit-lock.elc \ |
| 174 | ${datadir}/${BPN}/${PV}/lisp/jka-cmpr-hook.elc \ |
Andrew Geissler | 5082cc7 | 2023-09-11 08:41:39 -0400 | [diff] [blame] | 175 | ${datadir}/${BPN}/${PV}/lisp/jka-compr.elc \ |
| 176 | ${datadir}/${BPN}/${PV}/lisp/keymap.elc \ |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 177 | ${datadir}/${BPN}/${PV}/lisp/language/burmese.elc \ |
| 178 | ${datadir}/${BPN}/${PV}/lisp/language/cham.elc \ |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 179 | ${datadir}/${BPN}/${PV}/lisp/language/chinese.elc \ |
| 180 | ${datadir}/${BPN}/${PV}/lisp/language/cyrillic.elc \ |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 181 | ${datadir}/${BPN}/${PV}/lisp/language/czech.elc \ |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 182 | ${datadir}/${BPN}/${PV}/lisp/language/english.elc \ |
| 183 | ${datadir}/${BPN}/${PV}/lisp/language/ethiopic.elc \ |
| 184 | ${datadir}/${BPN}/${PV}/lisp/language/european.elc \ |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 185 | ${datadir}/${BPN}/${PV}/lisp/language/georgian.elc \ |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 186 | ${datadir}/${BPN}/${PV}/lisp/language/greek.elc \ |
| 187 | ${datadir}/${BPN}/${PV}/lisp/language/hebrew.elc \ |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 188 | ${datadir}/${BPN}/${PV}/lisp/language/indian.elc \ |
Andrew Geissler | 5082cc7 | 2023-09-11 08:41:39 -0400 | [diff] [blame] | 189 | ${datadir}/${BPN}/${PV}/lisp/language/indonesian.elc \ |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 190 | ${datadir}/${BPN}/${PV}/lisp/language/japanese.elc \ |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 191 | ${datadir}/${BPN}/${PV}/lisp/language/khmer.elc \ |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 192 | ${datadir}/${BPN}/${PV}/lisp/language/korean.elc \ |
| 193 | ${datadir}/${BPN}/${PV}/lisp/language/lao.elc \ |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 194 | ${datadir}/${BPN}/${PV}/lisp/language/misc-lang.elc \ |
Andrew Geissler | 5082cc7 | 2023-09-11 08:41:39 -0400 | [diff] [blame] | 195 | ${datadir}/${BPN}/${PV}/lisp/language/philippine.elc \ |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 196 | ${datadir}/${BPN}/${PV}/lisp/language/romanian.elc \ |
| 197 | ${datadir}/${BPN}/${PV}/lisp/language/sinhala.elc \ |
| 198 | ${datadir}/${BPN}/${PV}/lisp/language/slovak.elc \ |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 199 | ${datadir}/${BPN}/${PV}/lisp/language/tai-viet.elc \ |
| 200 | ${datadir}/${BPN}/${PV}/lisp/language/thai.elc \ |
| 201 | ${datadir}/${BPN}/${PV}/lisp/language/tibetan.elc \ |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 202 | ${datadir}/${BPN}/${PV}/lisp/language/utf-8-lang.elc \ |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 203 | ${datadir}/${BPN}/${PV}/lisp/language/vietnamese.elc \ |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 204 | ${datadir}/${BPN}/${PV}/lisp/ldefs-boot.el \ |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 205 | ${datadir}/${BPN}/${PV}/lisp/loaddefs.el \ |
| 206 | ${datadir}/${BPN}/${PV}/lisp/loadup.el \ |
| 207 | ${datadir}/${BPN}/${PV}/lisp/menu-bar.elc \ |
| 208 | ${datadir}/${BPN}/${PV}/lisp/minibuffer.elc \ |
| 209 | ${datadir}/${BPN}/${PV}/lisp/mouse.elc \ |
| 210 | ${datadir}/${BPN}/${PV}/lisp/newcomment.elc \ |
| 211 | ${datadir}/${BPN}/${PV}/lisp/obarray.elc \ |
| 212 | ${datadir}/${BPN}/${PV}/lisp/paren.elc \ |
| 213 | ${datadir}/${BPN}/${PV}/lisp/progmodes/elisp-mode.elc \ |
| 214 | ${datadir}/${BPN}/${PV}/lisp/progmodes/prog-mode.elc \ |
| 215 | ${datadir}/${BPN}/${PV}/lisp/register.elc \ |
| 216 | ${datadir}/${BPN}/${PV}/lisp/replace.elc \ |
| 217 | ${datadir}/${BPN}/${PV}/lisp/rfn-eshadow.elc \ |
| 218 | ${datadir}/${BPN}/${PV}/lisp/select.elc \ |
| 219 | ${datadir}/${BPN}/${PV}/lisp/simple.elc \ |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 220 | ${datadir}/${BPN}/${PV}/lisp/startup.elc \ |
| 221 | ${datadir}/${BPN}/${PV}/lisp/subr.elc \ |
| 222 | ${datadir}/${BPN}/${PV}/lisp/tab-bar.elc \ |
| 223 | ${datadir}/${BPN}/${PV}/lisp/term/tty-colors.elc \ |
| 224 | ${datadir}/${BPN}/${PV}/lisp/term/xterm.elc \ |
| 225 | ${datadir}/${BPN}/${PV}/lisp/textmodes/fill.elc \ |
| 226 | ${datadir}/${BPN}/${PV}/lisp/textmodes/page.elc \ |
| 227 | ${datadir}/${BPN}/${PV}/lisp/textmodes/paragraphs.elc \ |
| 228 | ${datadir}/${BPN}/${PV}/lisp/textmodes/text-mode.elc \ |
Andrew Geissler | 5082cc7 | 2023-09-11 08:41:39 -0400 | [diff] [blame] | 229 | ${datadir}/${BPN}/${PV}/lisp/thingatpt.elc \ |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 230 | ${datadir}/${BPN}/${PV}/lisp/tooltip.elc \ |
| 231 | ${datadir}/${BPN}/${PV}/lisp/uniquify.elc \ |
| 232 | ${datadir}/${BPN}/${PV}/lisp/vc/ediff-hook.elc \ |
| 233 | ${datadir}/${BPN}/${PV}/lisp/vc/vc-hooks.elc \ |
| 234 | ${datadir}/${BPN}/${PV}/lisp/version.elc \ |
| 235 | ${datadir}/${BPN}/${PV}/lisp/widget.elc \ |
| 236 | ${datadir}/${BPN}/${PV}/lisp/window.elc \ |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 237 | ${prefix}/libexec \ |
| 238 | " |
| 239 | |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 240 | # What works for "most" is relative, but this can be easily extended if needed |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 241 | FILES:${PN}-base = " \ |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 242 | ${datadir}/${BPN}/${PV}/etc/e \ |
| 243 | ${datadir}/${BPN}/${PV}/etc/forms \ |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 244 | ${datadir}/${BPN}/${PV}/etc/srecode \ |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 245 | ${datadir}/${BPN}/${PV}/etc/themes/adwaita-theme.el \ |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 246 | ${datadir}/${BPN}/${PV}/etc/themes/deeper-blue-theme.el \ |
| 247 | ${datadir}/${BPN}/${PV}/etc/themes/light-blue-theme.el \ |
| 248 | ${datadir}/${BPN}/${PV}/etc/themes/misterioso-theme.el \ |
| 249 | ${datadir}/${BPN}/${PV}/etc/themes/tango-theme.el \ |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 250 | ${datadir}/${BPN}/${PV}/etc/themes/wheatgrass-theme.el \ |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 251 | ${datadir}/${BPN}/${PV}/etc/themes/wombat-theme.el \ |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 252 | ${datadir}/${BPN}/${PV}/lisp/ansi-color.elc \ |
| 253 | ${datadir}/${BPN}/${PV}/lisp/auth-source.elc \ |
| 254 | ${datadir}/${BPN}/${PV}/lisp/calendar/iso8601.elc \ |
| 255 | ${datadir}/${BPN}/${PV}/lisp/calendar/parse-time.elc \ |
| 256 | ${datadir}/${BPN}/${PV}/lisp/calendar/time-date.elc \ |
| 257 | ${datadir}/${BPN}/${PV}/lisp/cedet \ |
| 258 | ${datadir}/${BPN}/${PV}/lisp/comint.elc \ |
| 259 | ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/cl-lib.elc \ |
| 260 | ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/cl-macs.elc \ |
| 261 | ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/cl-seq.elc \ |
| 262 | ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/eieio-core.elc \ |
| 263 | ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/eieio.elc \ |
| 264 | ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/inline.elc \ |
| 265 | ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/pcase.elc \ |
| 266 | ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/ring.elc \ |
| 267 | ${datadir}/${BPN}/${PV}/lisp/emacs-lisp/smie.elc \ |
| 268 | ${datadir}/${BPN}/${PV}/lisp/files-x.elc \ |
| 269 | ${datadir}/${BPN}/${PV}/lisp/format-spec.elc \ |
| 270 | ${datadir}/${BPN}/${PV}/lisp/json.elc \ |
| 271 | ${datadir}/${BPN}/${PV}/lisp/ls-lisp.elc \ |
| 272 | ${datadir}/${BPN}/${PV}/lisp/net/tramp-compat.elc \ |
| 273 | ${datadir}/${BPN}/${PV}/lisp/net/tramp-integration.elc \ |
| 274 | ${datadir}/${BPN}/${PV}/lisp/net/tramp-loaddefs.el \ |
| 275 | ${datadir}/${BPN}/${PV}/lisp/net/tramp-sh.elc \ |
| 276 | ${datadir}/${BPN}/${PV}/lisp/net/tramp.elc \ |
| 277 | ${datadir}/${BPN}/${PV}/lisp/net/trampver.elc \ |
| 278 | ${datadir}/${BPN}/${PV}/lisp/password-cache.elc \ |
| 279 | ${datadir}/${BPN}/${PV}/lisp/pcomplete.elc \ |
| 280 | ${datadir}/${BPN}/${PV}/lisp/progmodes/*asm* \ |
| 281 | ${datadir}/${BPN}/${PV}/lisp/progmodes/*perl* \ |
| 282 | ${datadir}/${BPN}/${PV}/lisp/progmodes/cc-align.elc \ |
| 283 | ${datadir}/${BPN}/${PV}/lisp/progmodes/cc-cmds.elc \ |
| 284 | ${datadir}/${BPN}/${PV}/lisp/progmodes/cc-defs.elc \ |
| 285 | ${datadir}/${BPN}/${PV}/lisp/progmodes/cc-engine.elc \ |
| 286 | ${datadir}/${BPN}/${PV}/lisp/progmodes/cc-fonts.elc \ |
| 287 | ${datadir}/${BPN}/${PV}/lisp/progmodes/cc-guess.elc \ |
| 288 | ${datadir}/${BPN}/${PV}/lisp/progmodes/cc-menus.elc \ |
| 289 | ${datadir}/${BPN}/${PV}/lisp/progmodes/cc-mode.elc \ |
| 290 | ${datadir}/${BPN}/${PV}/lisp/progmodes/cc-styles.elc \ |
| 291 | ${datadir}/${BPN}/${PV}/lisp/progmodes/cc-vars.elc \ |
| 292 | ${datadir}/${BPN}/${PV}/lisp/progmodes/cpp* \ |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 293 | ${datadir}/${BPN}/${PV}/lisp/progmodes/executable* \ |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 294 | ${datadir}/${BPN}/${PV}/lisp/progmodes/make* \ |
| 295 | ${datadir}/${BPN}/${PV}/lisp/progmodes/prog* \ |
| 296 | ${datadir}/${BPN}/${PV}/lisp/progmodes/python* \ |
| 297 | ${datadir}/${BPN}/${PV}/lisp/progmodes/sh-script* \ |
| 298 | ${datadir}/${BPN}/${PV}/lisp/shell.elc \ |
| 299 | ${datadir}/${BPN}/${PV}/lisp/subdirs.el \ |
| 300 | ${datadir}/${BPN}/${PV}/site-lisp/ \ |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 301 | " |
| 302 | |
| 303 | # Restore FILES for the full package to catch everything left |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 304 | FILES:${PN}-full = "${FILES:${PN}}" |
| 305 | FILES:${PN}-full:append = " ${datadir}/icons" |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 306 | |
| 307 | |
| 308 | # The following does NOT build a native emacs. |
| 309 | # It only builds some parts of it that are |
| 310 | # required to by the build for target emacs. |
| 311 | BBCLASSEXTEND = "native" |