Andrew Jeffery | 8c8fb8b | 2022-01-27 10:19:17 +1030 | [diff] [blame] | 1 | FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:" |
| 2 | |
Andrew Jeffery | 096c600 | 2022-08-08 20:48:00 +0930 | [diff] [blame] | 3 | SRC_URI:append:p10bmc = " file://ibm.json file://ips.json file://keys/" |
Andrew Jeffery | 8c8fb8b | 2022-01-27 10:19:17 +1030 | [diff] [blame] | 4 | |
Andrew Jeffery | 096c600 | 2022-08-08 20:48:00 +0930 | [diff] [blame] | 5 | OTPTOOL_CONFIGS:p10bmc = "${WORKDIR}/ibm.json ${WORKDIR}/ips.json" |
Andrew Jeffery | 8c8fb8b | 2022-01-27 10:19:17 +1030 | [diff] [blame] | 6 | OTPTOOL_KEY_DIR:p10bmc = "${WORKDIR}/keys/" |
| 7 | |
| 8 | # !!! Do not copy p10bmc's use of little-endian key ordering !!! |
| 9 | # |
| 10 | # The prefered order for production silicon is big-endian. Little-endian is necessary for p10bmc |
| 11 | # platforms due to development history involving pre-production AST2600 silicon. More discussion |
| 12 | # here: |
| 13 | # |
| 14 | # https://gerrit.openbmc-project.xyz/c/openbmc/openbmc/+/50716 |
| 15 | SOCSEC_SIGN_EXTRA_OPTS = "--rsa_key_order=little" |
| 16 | |
| 17 | do_deploy:prepend:p10bmc() { |
| 18 | # otptool needs access to the public and private socsec signing keys in the keys/ directory |
| 19 | openssl rsa -in ${SOCSEC_SIGN_KEY} -pubout > ${WORKDIR}/keys/rsa_pub_oem_dss_key.pem |
| 20 | } |