blob: 6acd00324b6881c360d45d77e55fe4dea6549ef8 [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "Portable C library for multiline text editing"
2HOMEPAGE = "http://projects.gnome.org/gtksourceview/"
3
4LICENSE = "LGPL-2.1-only"
5LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
6
7DEPENDS = "gtk+3 libxml2 intltool-native gnome-common-native glib-2.0-native"
8
9PNAME = "gtksourceview"
10
11S = "${WORKDIR}/${PNAME}-${PV}"
12
13
14inherit gnomebase lib_package gettext features_check gtk-doc gobject-introspection vala
15
16ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
17
18SRC_URI = "https://download.gnome.org/sources/gtksourceview/4.8/${PNAME}-${PV}.tar.xz"
19SRC_URI[sha256sum] = "7ec9d18fb283d1f84a3a3eff3b7a72b09a10c9c006597b3fbabbb5958420a87d"
20
21GIR_MESON_OPTION = 'gir'
22GTKDOC_MESON_OPTION = "gtk_doc"
23
24# Override the definition in meson.bbclass. The dependencies in mason.build are incomplete
25# and the recipe will not build with "-j 1". This fix is benign but should be reviewed when
26# updating versions.
27#
28meson_do_compile() {
29 bbnote "========== generating gtksourceview-gresources.h ========"
30 bbnote "PARALLEL_MAKE is ${PARALLEL_MAKE}"
31 ninja ${PARALLEL_MAKE} gtksourceview/gtksourceview-gresources.h
32 bbnote "========== compiling target all ========"
33 ninja ${PARALLEL_MAKE}
34}
35
36FILES:${PN} += "${datadir}/gtksourceview-4"