Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "Python Imaging Library (Fork). Pillow is the friendly PIL fork by Alex \ |
| 2 | Clark and Contributors. PIL is the Python Imaging Library by Fredrik Lundh and \ |
| 3 | Contributors." |
| 4 | HOMEPAGE = "https://pillow.readthedocs.io" |
| 5 | LICENSE = "MIT" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=c6379001ecb47e2a0420c40177fc1125" |
| 7 | |
| 8 | SRC_URI = "git://github.com/python-pillow/Pillow.git;branch=5.4.x \ |
| 9 | file://0001-support-cross-compiling.patch \ |
| 10 | file://0001-explicitly-set-compile-options.patch \ |
| 11 | " |
| 12 | SRCREV ?= "f38f01bbe3a0a9f49ce592c86ff20c01c9655133" |
| 13 | |
| 14 | |
| 15 | inherit setuptools3 |
| 16 | |
| 17 | DEPENDS += " \ |
| 18 | zlib \ |
| 19 | jpeg \ |
| 20 | tiff \ |
| 21 | freetype \ |
| 22 | lcms \ |
| 23 | openjpeg \ |
| 24 | " |
| 25 | |
| 26 | S = "${WORKDIR}/git" |
| 27 | |
| 28 | BBCLASSEXTEND = "native" |