Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "Utilities and libraries for handling compiled object files" |
| 2 | HOMEPAGE = "https://sourceware.org/elfutils" |
| 3 | SECTION = "base" |
| 4 | LICENSE = "(GPLv3 & Elfutils-Exception)" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" |
| 6 | DEPENDS = "libtool bzip2 zlib virtual/libintl" |
| 7 | DEPENDS_append_libc-musl = " argp-standalone fts " |
| 8 | # The Debian patches below are from: |
| 9 | # http://ftp.de.debian.org/debian/pool/main/e/elfutils/elfutils_0.175-1.debian.tar.xz |
| 10 | SRC_URI = "https://sourceware.org/elfutils/ftp/${PV}/${BP}.tar.bz2 \ |
| 11 | file://0001-dso-link-change.patch \ |
| 12 | file://0002-Fix-elf_cvt_gunhash-if-dest-and-src-are-same.patch \ |
| 13 | file://0003-fixheadercheck.patch \ |
| 14 | file://0004-Disable-the-test-to-convert-euc-jp.patch \ |
| 15 | file://0006-Fix-build-on-aarch64-musl.patch \ |
| 16 | file://0007-Fix-control-path-where-we-have-str-as-uninitialized-.patch \ |
| 17 | file://0001-libasm-may-link-with-libbz2-if-found.patch \ |
| 18 | file://0001-libelf-elf_end.c-check-data_list.data.d.d_buf-before.patch \ |
| 19 | file://debian/hppa_backend.diff \ |
| 20 | file://debian/arm_backend.diff \ |
| 21 | file://debian/mips_backend.diff \ |
| 22 | file://debian/mips_readelf_w.patch \ |
| 23 | file://debian/kfreebsd_path.patch \ |
| 24 | file://debian/0001-Ignore-differences-between-mips-machine-identifiers.patch \ |
| 25 | file://debian/0002-Add-support-for-mips64-abis-in-mips_retval.c.patch \ |
| 26 | file://debian/0003-Add-mips-n64-relocation-format-hack.patch \ |
| 27 | file://debian/hurd_path.patch \ |
| 28 | file://debian/ignore_strmerge.diff \ |
| 29 | file://debian/disable_werror.patch \ |
| 30 | " |
| 31 | SRC_URI_append_libc-musl = " file://0008-build-Provide-alternatives-for-glibc-assumptions-hel.patch" |
| 32 | |
| 33 | SRC_URI[md5sum] = "077e4f49320cad82bf17a997068b1db9" |
| 34 | SRC_URI[sha256sum] = "eb5747c371b0af0f71e86215a5ebb88728533c3a104a43d4231963f308cd1023" |
| 35 | |
| 36 | inherit autotools gettext |
| 37 | |
| 38 | EXTRA_OECONF = "--program-prefix=eu- --without-lzma" |
| 39 | EXTRA_OECONF_append_class-native = " --without-bzlib" |
| 40 | |
| 41 | do_install_append() { |
| 42 | if [ "${TARGET_ARCH}" != "x86_64" ] && [ -z `echo "${TARGET_ARCH}"|grep 'i.86'` ];then |
| 43 | rm -f ${D}${bindir}/eu-objdump |
| 44 | fi |
| 45 | } |
| 46 | |
| 47 | EXTRA_OEMAKE_class-native = "" |
| 48 | EXTRA_OEMAKE_class-nativesdk = "" |
| 49 | |
| 50 | ALLOW_EMPTY_${PN}_libc-musl = "1" |
| 51 | |
| 52 | BBCLASSEXTEND = "native nativesdk" |
| 53 | |
| 54 | # Package utilities separately |
| 55 | PACKAGES =+ "${PN}-binutils libelf libasm libdw" |
| 56 | FILES_${PN}-binutils = "\ |
| 57 | ${bindir}/eu-addr2line \ |
| 58 | ${bindir}/eu-ld \ |
| 59 | ${bindir}/eu-nm \ |
| 60 | ${bindir}/eu-readelf \ |
| 61 | ${bindir}/eu-size \ |
| 62 | ${bindir}/eu-strip" |
| 63 | |
| 64 | FILES_libelf = "${libdir}/libelf-${PV}.so ${libdir}/libelf.so.*" |
| 65 | FILES_libasm = "${libdir}/libasm-${PV}.so ${libdir}/libasm.so.*" |
| 66 | FILES_libdw = "${libdir}/libdw-${PV}.so ${libdir}/libdw.so.* ${libdir}/elfutils/lib*" |
| 67 | # Some packages have the version preceeding the .so instead properly |
| 68 | # versioned .so.<version>, so we need to reorder and repackage. |
| 69 | #FILES_${PN} += "${libdir}/*-${PV}.so ${base_libdir}/*-${PV}.so" |
| 70 | #FILES_SOLIBSDEV = "${libdir}/libasm.so ${libdir}/libdw.so ${libdir}/libelf.so" |
| 71 | |
| 72 | # The package contains symlinks that trip up insane |
| 73 | INSANE_SKIP_${MLPREFIX}libdw = "dev-so" |