blob: fe9c038f5c174798681386773a6b679e287d1adf [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "A client for the Cisco3000 VPN Concentrator"
2HOMEPAGE = "http://www.unix-ag.uni-kl.de/~massar/vpnc/"
Patrick Williamsb48b7b42016-08-17 15:04:38 -05003SECTION = "net"
Andrew Geissler9aee5002022-03-30 16:27:02 +00004LICENSE = "GPL-2.0-or-later"
Patrick Williamsb48b7b42016-08-17 15:04:38 -05005LIC_FILES_CHKSUM = "file://COPYING;md5=173b74cb8ac640a9992c03f3bce22a33"
Patrick Williamsb48b7b42016-08-17 15:04:38 -05006
Brad Bishop6e60e8b2018-02-01 10:27:11 -05007DEPENDS += "libgcrypt"
Patrick Williamsb48b7b42016-08-17 15:04:38 -05008
Brad Bishop6e60e8b2018-02-01 10:27:11 -05009PV .= "r550-2jnpr1"
10SRCREV = "b1243d29e0c00312ead038b04a2cf5e2fa31d740"
Andrew Geissler595f6302022-01-24 19:11:47 +000011SRC_URI = "git://github.com/ndpgroup/vpnc;branch=master;protocol=https \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050012 file://long-help \
13 file://default.conf \
14 file://0001-search-for-log-help-in-build-dir.patch \
15 file://0002-Fix-vpnc-install-for-cross-compile.patch \
16 file://0003-error.h-is-specific-to-glibc-on-linux.patch \
17 file://0004-Use-pkgconfig-instead-of-libgcrypt-config.patch \
18 file://0005-include-sys-ttydefaults.h-for-CEOT-definition.patch \
19 file://0006-sysdep-Add-header-include-sequence-to-adjust-for-mus.patch \
20 file://0007-add-error-API-when-error.h-is-not-on-platform.patch \
21 file://0008-include-sysdep.h-before-net-if_tun.h.patch \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050022 file://0009-reduce-lifetime-value.patch \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050023 "
24
25PACKAGECONFIG ?= "gnutls"
26
27PACKAGECONFIG[gnutls] = ",,gnutls"
28PACKAGECONFIG[openssl] = ",,openssl"
29
Andrew Geissler82c905d2020-04-13 13:39:40 -050030PACKAGES =+ "${PN}-script"
31
Brad Bishop6e60e8b2018-02-01 10:27:11 -050032S = "${WORKDIR}/git"
33
34inherit perlnative pkgconfig
35
36#EXTRA_OEMAKE = "-e MAKEFLAGS="
Patrick Williamsb48b7b42016-08-17 15:04:38 -050037
Patrick Williams213cb262021-08-07 19:21:33 -050038do_configure:append () {
Patrick Williamsb48b7b42016-08-17 15:04:38 -050039 # Make sure we use our nativeperl wrapper
40 sed -i "1s:#!.*:#!/usr/bin/env nativeperl:" ${S}/*.pl
Brad Bishop6e60e8b2018-02-01 10:27:11 -050041 cp ${WORKDIR}/long-help ${S}
Patrick Williamsb48b7b42016-08-17 15:04:38 -050042}
43
44do_install () {
Patrick Williamsddad1a12017-02-23 20:36:32 -060045 sed -i s:m600:m\ 600:g Makefile
Patrick Williamsb48b7b42016-08-17 15:04:38 -050046 oe_runmake 'DESTDIR=${D}' 'PREFIX=/usr' install
47 rm -f ${D}${sysconfdir}/vpnc/vpnc.conf #This file is useless
48 install ${WORKDIR}/default.conf ${D}${sysconfdir}/vpnc/default.conf
49}
50
51SYSROOT_PREPROCESS_FUNCS += "vpnc_sysroot_preprocess"
52
53vpnc_sysroot_preprocess () {
54 install -d ${SYSROOT_DESTDIR}${sysconfdir}/vpnc
55 install -m 755 ${D}${sysconfdir}/vpnc/vpnc-script ${SYSROOT_DESTDIR}${sysconfdir}/vpnc
56}
57
Patrick Williams213cb262021-08-07 19:21:33 -050058FILES:${PN}-script = "${sysconfdir}/vpnc/vpnc-script"
Andrew Geissler82c905d2020-04-13 13:39:40 -050059
Patrick Williams213cb262021-08-07 19:21:33 -050060CONFFILES:${PN} = "${sysconfdir}/vpnc/default.conf"
61RDEPENDS:${PN} = "perl-module-io-file ${PN}-script"
62RRECOMMENDS:${PN} = "kernel-module-tun"