Patrick Venture | 9afb671 | 2018-09-17 17:14:46 -0700 | [diff] [blame] | 1 | SUMMARY = "Google Sys OEM commands" |
Patrick Venture | edb6192 | 2018-09-21 14:57:58 -0700 | [diff] [blame] | 2 | DESCRIPTION = "Google Sys OEM commands" |
Patrick Venture | 3adb97a | 2018-09-26 08:42:56 -0700 | [diff] [blame] | 3 | HOMEPAGE = "https://github.com/openbmc/google-ipmi-sys" |
| 4 | PR = "r1" |
| 5 | PV = "0.1+git${SRCPV}" |
| 6 | LICENSE = "Apache-2.0" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327" |
Patrick Venture | 9afb671 | 2018-09-17 17:14:46 -0700 | [diff] [blame] | 8 | |
Andrew Geissler | f64c3c0 | 2021-06-24 11:00:17 +0000 | [diff] [blame] | 9 | inherit meson pkgconfig systemd |
Patrick Venture | 9afb671 | 2018-09-17 17:14:46 -0700 | [diff] [blame] | 10 | |
Andrew Geissler | f64c3c0 | 2021-06-24 11:00:17 +0000 | [diff] [blame] | 11 | DEPENDS += " \ |
| 12 | nlohmann-json \ |
| 13 | phosphor-dbus-interfaces \ |
| 14 | phosphor-logging \ |
| 15 | phosphor-ipmi-host \ |
| 16 | sdbusplus \ |
| 17 | systemd \ |
| 18 | " |
Patrick Venture | 9afb671 | 2018-09-17 17:14:46 -0700 | [diff] [blame] | 19 | |
Patrick Venture | 9afb671 | 2018-09-17 17:14:46 -0700 | [diff] [blame] | 20 | S = "${WORKDIR}/git" |
Patrick Williams | bb99d22 | 2022-01-24 15:55:09 -0600 | [diff] [blame] | 21 | SRC_URI = "git://github.com/openbmc/google-ipmi-sys;branch=master;protocol=https" |
Andrew Geissler | fd21f6d | 2023-03-29 20:00:32 -0500 | [diff] [blame] | 22 | SRCREV = "59445f5e211b833349ddcb68eb05c727d373c2e9" |
Patrick Venture | 9afb671 | 2018-09-17 17:14:46 -0700 | [diff] [blame] | 23 | |
Willy Tu | 4dd03ca | 2021-08-06 09:37:35 -0700 | [diff] [blame] | 24 | FILES:${PN} += "${libdir}/ipmid-providers" |
Patrick Venture | 9afb671 | 2018-09-17 17:14:46 -0700 | [diff] [blame] | 25 | |
| 26 | SYSTEMD_PACKAGES = "${PN}" |
Willy Tu | 4dd03ca | 2021-08-06 09:37:35 -0700 | [diff] [blame] | 27 | SYSTEMD_SERVICE:${PN} += " \ |
Andrew Geissler | f64c3c0 | 2021-06-24 11:00:17 +0000 | [diff] [blame] | 28 | gbmc-host-poweroff.target \ |
| 29 | gbmc-psu-hardreset.target \ |
Andrew Geissler | 1e9d916 | 2022-04-07 20:30:13 +0000 | [diff] [blame] | 30 | gbmc-psu-hardreset-pre.target \ |
| 31 | gbmc-psu-hardreset-time.service \ |
Andrew Geissler | f64c3c0 | 2021-06-24 11:00:17 +0000 | [diff] [blame] | 32 | " |
Patrick Venture | 9afb671 | 2018-09-17 17:14:46 -0700 | [diff] [blame] | 33 | |
Andrew Geissler | f64c3c0 | 2021-06-24 11:00:17 +0000 | [diff] [blame] | 34 | EXTRA_OEMESON += "-Dtests=disabled" |
William A. Kennington III | a4cdbe6 | 2021-06-04 18:13:35 -0700 | [diff] [blame] | 35 | |
Willy Tu | 4dd03ca | 2021-08-06 09:37:35 -0700 | [diff] [blame] | 36 | CXXFLAGS:append:gbmc = '${@"" if not d.getVar("GBMC_NCSI_IF_NAME") else \ |
William A. Kennington III | 577d20f | 2021-02-17 14:33:38 -0800 | [diff] [blame] | 37 | " -DNCSI_IPMI_CHANNEL=1 -DNCSI_IF_NAME=" + d.getVar("GBMC_NCSI_IF_NAME")}' |