Karthikeyan Pasupathi | 36f035b | 2022-08-28 17:35:29 +0530 | [diff] [blame] | 1 | FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:" |
| 2 | |
Delphine CC Chiu | 0528ecd | 2022-11-03 15:40:43 +0800 | [diff] [blame^] | 3 | HOST_DEFAULT_TARGETS:append = " \ |
Karthikeyan Pasupathi | 36f035b | 2022-08-28 17:35:29 +0530 | [diff] [blame] | 4 | obmc-host-shutdown@{}.target.wants/host-poweroff@{}.service \ |
| 5 | obmc-host-start@{}.target.wants/host-poweron@{}.service \ |
| 6 | obmc-host-reboot@{}.target.wants/host-powercycle@{}.service \ |
Delphine CC Chiu | 0528ecd | 2022-11-03 15:40:43 +0800 | [diff] [blame^] | 7 | obmc-host-force-warm-reboot@{}.target.wants/host-powerreset@{}.service \ |
Karthikeyan Pasupathi | 36f035b | 2022-08-28 17:35:29 +0530 | [diff] [blame] | 8 | " |
Delphine CC Chiu | 0528ecd | 2022-11-03 15:40:43 +0800 | [diff] [blame^] | 9 | |
| 10 | CHASSIS_DEFAULT_TARGETS:append = " \ |
| 11 | obmc-chassis-poweron@{}.target.wants/chassis-poweron@{}.service \ |
| 12 | obmc-chassis-hard-poweroff@{}.target.wants/chassis-poweroff@{}.service \ |
| 13 | obmc-chassis-powercycle@{}.target.wants/chassis-powercycle@{}.service \ |
| 14 | " |
| 15 | |
| 16 | CHASSIS_DEFAULT_TARGETS:remove = " \ |
Karthikeyan Pasupathi | 60e2e53 | 2023-01-20 19:54:43 +0530 | [diff] [blame] | 17 | obmc-chassis-poweroff@{}.target.requires/obmc-powered-off@{}.service \ |
| 18 | " |
Karthikeyan Pasupathi | 36f035b | 2022-08-28 17:35:29 +0530 | [diff] [blame] | 19 | |
| 20 | SRC_URI:append:greatlakes = " \ |
| 21 | file://chassis-poweroff@.service \ |
| 22 | file://chassis-poweron@.service \ |
Delphine CC Chiu | 0528ecd | 2022-11-03 15:40:43 +0800 | [diff] [blame^] | 23 | file://chassis-powercycle@.service \ |
Karthikeyan Pasupathi | 36f035b | 2022-08-28 17:35:29 +0530 | [diff] [blame] | 24 | file://host-poweroff@.service \ |
| 25 | file://host-poweron@.service \ |
| 26 | file://host-powercycle@.service \ |
Delphine CC Chiu | 0528ecd | 2022-11-03 15:40:43 +0800 | [diff] [blame^] | 27 | file://host-powerreset@.service \ |
Karthikeyan Pasupathi | 36f035b | 2022-08-28 17:35:29 +0530 | [diff] [blame] | 28 | file://chassis-poweroff \ |
| 29 | file://chassis-poweron \ |
Delphine CC Chiu | 0528ecd | 2022-11-03 15:40:43 +0800 | [diff] [blame^] | 30 | file://chassis-powercycle \ |
Karthikeyan Pasupathi | 36f035b | 2022-08-28 17:35:29 +0530 | [diff] [blame] | 31 | file://host-poweroff \ |
| 32 | file://host-poweron \ |
| 33 | file://host-powercycle \ |
Delphine CC Chiu | 0528ecd | 2022-11-03 15:40:43 +0800 | [diff] [blame^] | 34 | file://host-powerreset \ |
Karthikeyan Pasupathi | 36f035b | 2022-08-28 17:35:29 +0530 | [diff] [blame] | 35 | file://power-cmd \ |
| 36 | " |
| 37 | |
| 38 | RDEPENDS:${PN}:append:greatlakes = " bash" |
| 39 | |
| 40 | do_install:append:greatlakes() { |
| 41 | install -d ${D}${systemd_system_unitdir} |
| 42 | install -m 0644 ${WORKDIR}/*.service ${D}${systemd_system_unitdir}/ |
| 43 | |
| 44 | install -d ${D}${libexecdir} |
| 45 | install -m 0777 ${WORKDIR}/chassis-poweroff ${D}${libexecdir}/ |
| 46 | install -m 0777 ${WORKDIR}/chassis-poweron ${D}${libexecdir}/ |
Delphine CC Chiu | 0528ecd | 2022-11-03 15:40:43 +0800 | [diff] [blame^] | 47 | install -m 0777 ${WORKDIR}/chassis-powercycle ${D}${libexecdir}/ |
Karthikeyan Pasupathi | 36f035b | 2022-08-28 17:35:29 +0530 | [diff] [blame] | 48 | install -m 0777 ${WORKDIR}/host-poweroff ${D}${libexecdir}/ |
| 49 | install -m 0777 ${WORKDIR}/host-poweron ${D}${libexecdir}/ |
| 50 | install -m 0777 ${WORKDIR}/host-powercycle ${D}${libexecdir}/ |
Delphine CC Chiu | 0528ecd | 2022-11-03 15:40:43 +0800 | [diff] [blame^] | 51 | install -m 0777 ${WORKDIR}/host-powerreset ${D}${libexecdir}/ |
Karthikeyan Pasupathi | 36f035b | 2022-08-28 17:35:29 +0530 | [diff] [blame] | 52 | install -m 0777 ${WORKDIR}/power-cmd ${D}${libexecdir}/ |
| 53 | } |
| 54 | FILES:${PN} += " /lib/systemd/system/*.service" |