Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame^] | 1 | SUMMARY = "Paho MQTT - C libraries for the MQTT and MQTT-SN protocols" |
| 2 | DESCRIPTION = "Client implementation of open and standard messaging protocols for Machine-to-Machine (M2M) and Internet of Things (IoT)." |
| 3 | HOMEPAGE = "http://www.eclipse.org/paho/" |
| 4 | SECTION = "console/network" |
| 5 | LICENSE = "EPL-1.0 | EDL-1.0" |
| 6 | |
| 7 | LIC_FILES_CHKSUM = " \ |
| 8 | file://edl-v10;md5=3adfcc70f5aeb7a44f3f9b495aa1fbf3 \ |
| 9 | file://epl-v20;md5=d9fc0efef5228704e7f5b37f27192723 \ |
| 10 | file://notice.html;md5=943f861069889acecebf51dfa24478e2 \ |
| 11 | file://about.html;md5=e5662cbb5f8fd5c9faac526e4077898e \ |
| 12 | " |
| 13 | |
| 14 | SRC_URI = "git://github.com/eclipse/paho.mqtt.c;protocol=http \ |
| 15 | file://0001-Fix-bug-of-free-with-musl.patch" |
| 16 | |
| 17 | SRCREV = "fbe39064c4416f879308a8a5390b19d544970789" |
| 18 | |
| 19 | DEPENDS = "openssl" |
| 20 | |
| 21 | S = "${WORKDIR}/git" |
| 22 | |
| 23 | inherit cmake |
| 24 | |
| 25 | do_install_append() { |
| 26 | # paho-mqtt installes some thing that we don't want. |
| 27 | rm -rf ${D}${prefix}/samples |
| 28 | find ${D}${prefix} -maxdepth 1 -type f -delete |
| 29 | } |
| 30 | |
| 31 | EXTRA_OECMAKE = "-DPAHO_WITH_SSL=ON" |
| 32 | |
| 33 | do_configure_prepend_libc-musl() { |
| 34 | sed -i -e "s/SET(LIBS_SYSTEM c dl pthread anl rt)/SET(LIBS_SYSTEM c dl pthread rt)/g" ${S}/src/CMakeLists.txt |
| 35 | } |